码迷,mamicode.com
首页 > 其他好文 > 详细

133 - The Dole Queue

时间:2016-05-06 15:19:18      阅读:141      评论:0      收藏:0      [点我收藏+]

标签:

The Dole Queue

In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided on the following strategy. Every day all dole applicants will be placed in a large circle, facing inwards. Someone is arbitrarily chosen as number 1, and the rest are numbered counter-clockwise up to N (who will be standing on 1’s left). Starting from 1 and moving counter-clockwise, one labour official counts off k applicants, while another official starts from N and moves clockwise, counting m applicants. The two who are chosen are then sent off for retraining; if both officials pick the same person she (he) is sent off to become a politician. Each official then starts counting again at the next available person and the process continues until no-one is left. Note that the two victims (sorry, trainees) leave the ring simultaneously, so it is possible for one official to count a person already selected by the other official.

Input

Write a program that will successively read in (in that order) the three numbers (N, k and m; k, m > 0, 0 < N < 20) and determine the order in which the applicants are sent off for retraining. Each set of three numbers will be on a separate line and the end of data will be signalled by three zeroes (0 0 0).

Output

For each triplet, output a single line of numbers specifying the order in which people are chosen. Each number should be in a field of 3 characters. For pairs of numbers list the person chosen by the counter-clockwise official first. Separate successive pairs (or singletons) by commas (but there should not be a trailing comma).

Sample input

10 4 3
0 0 0

Sample output

技术分享 4 技术分享8, 技术分享9 技术分享5, 技术分享3 技术分享1, 技术分享2 技术分享6, 技术分享10, 技术分享7

where 技术分享represents a space.

n(n<20)个人站成一圈,逆时针编号为1~n。有两个官员,A从1开始逆时针数,B从n开始顺时针数。在每一轮中,官员A数k个就停下来,官员B数m个就停下来(注意有可能两个官员停在同一个人上)。接下来被官员选中的人(1个或者2个)离开队伍。输入n,k,m输出每轮里被选中的人的编号(如果有两个人,先输出被A选中的)。例如,n=10,k=4,m=3,输出为4 8, 9 5, 3 1, 2 6, 10, 7。注意:输出的每个数应当恰好占3列。

#include <stdio.h>
#include <string.h>
#define maxNum 25
// N为人数,k为军官1数的间隔人数
// m为军官2数的间隔人数
int N,k,m;
// 标记数组
int mark[maxNum];
// 剩余人数
int num;
// 军官1和军官2的当前位置
int kpos;
int mpos;
void choice() {
    int kt = k - 1;
    int mt = m - 1;
    while(kt || mark[kpos]) {
        if(!mark[kpos]) {
            kt--;
        }
        kpos++;
        if(kpos >= N + 1) {
            kpos = 1;
        }
    }
    while(mt || mark[mpos]) {
        if(!mark[mpos]) {
            mt--;
        }
        mpos--;
        if(mpos <= 0) {
            mpos = N;
        }
    }
    if (kpos == mpos && !mark[kpos]) {
        printf(" %c%c", (kpos) / 10 ? (kpos) / 10 + ‘0‘ : ‘ ‘, (kpos) % 10 + ‘0‘);
        mark[kpos] = 1;
        num--;
    } else if (kpos != mpos) {
        if(!mark[kpos]) {
            printf(" %c%c", (kpos) / 10 ? (kpos) / 10 + ‘0‘ : ‘ ‘, (kpos) % 10 + ‘0‘);
            mark[kpos] = 1;
            num--;
        }
        if(!mark[mpos]) {
            printf(" %c%c", (mpos) / 10 ? (mpos) / 10 + ‘0‘ : ‘ ‘, (mpos) % 10 + ‘0‘);
            mark[mpos] = 1;
            num--;
        }
    }
    if(num) {
        printf(",");
    } else {
        printf("\n");
    }
}

int main() {
    while(scanf("%d%d%d", &N, &k, &m) == 3 && N != 0) {
        // 每回合都重置标记数组
        memset(mark, 0, sizeof(mark));
        kpos = 1;
        mpos = N;
        num = N;
        while(num) {
            choice();
        }
    }

    return 0;
}

133 - The Dole Queue

标签:

原文地址:http://blog.csdn.net/q547550831/article/details/51322541

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!