码迷,mamicode.com
首页 > 其他好文 > 详细

UESTC 491 Tricks in Bits

时间:2016-05-06 16:12:12      阅读:110      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 1000MS   Memory Limit: 65535KB   64bit IO Format: %lld & %llu

 Status

Description

Given 技术分享N unsigned 技术分享技术分享64-bit integers, you can bitwise NOT each or not. Then you need to add operations selected from bitwise XORbitwise ORand bitwise AND, between any two successive integers and calculate the result. Your job is to make the result as small as possible.

Input

The first line of the input is 技术分享T (no more than 技术分享技术分享技术分享技术分享1000), which stands for the number of test cases you need to solve.

Then 技术分享T blocks follow. The first line of each block contains a single number 技术分享N (技术分享技术分享技术分享技术分享技术分享技术分享技术分享1≤N≤100) indicating the number of unsigned 技术分享技术分享64-bit integers. Then 技术分享n integers follow in the next line.

Output

For every test case, you should output Case #k: first, where 技术分享k indicates the case number and counts from 技术分享1. Then output the answer.

Sample Input



1 2 3 

3 6

Sample Output

Case #1: 0 

Case #2: 1


#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <stdio.h>
#include <math.h>

using namespace std;
typedef unsigned long long int LL;
int n;
LL ans;
LL MAX;
LL a[105];
LL min(LL a,LL b){return (a<b?a:b);}
void dfs(LL num,int cnt)
{
    if(ans==0)
        return;
    if(num==0)
    {
        ans=0;
        return;
    }
    if(cnt==n+1)
    {
        ans=min(ans,num);
        return;
    }
    dfs(num|(~a[cnt]),cnt+1);
    dfs(num&(~a[cnt]),cnt+1);
    dfs(num^(~a[cnt]),cnt+1);
    dfs(num|a[cnt],cnt+1);
    dfs(num&a[cnt],cnt+1);
    dfs(num^a[cnt],cnt+1);
}
int main()
{
    int t;
    scanf("%d",&t);
    int cas=0;
    while(t--)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            scanf("%llu",&a[i]);
        MAX=1;
		MAX<<=63;
		ans=MAX;
        dfs(a[1],2);
        dfs(~a[1],2);
        printf("Case #%d: %llu\n",++cas,ans);
    }
    return 0;
}


UESTC 491 Tricks in Bits

标签:

原文地址:http://blog.csdn.net/dacc123/article/details/51315848

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!