码迷,mamicode.com
首页 > 其他好文 > 详细

4582: [Usaco2016 Open]Diamond Collector

时间:2016-05-06 20:22:54      阅读:314      评论:0      收藏:0      [点我收藏+]

标签:

4582: [Usaco2016 Open]Diamond Collector

Description

Bessie the cow, always a fan of shiny objects, has taken up a hobby of mining diamonds in her spare 
time! She has collected N diamonds (N≤50,000) of varying sizes, and she wants to arrange some of them
in a pair of display cases in the barn.Since Bessie wants the diamonds in each of the two cases to
be relatively similar in size, she decides that she will not include two diamonds in the same case
 if their sizes differ by more than K (two diamonds can be displayed together in the same case if their
sizes differ by exactly K). Given K, please help Bessie determine the maximum number of diamonds
 she can display in both cases together.

Input

The first line of the input file contains N and K (0≤K≤1,000,000,000). The next NN lines each cont
ain an integer giving the size of one of the diamonds. All sizes will be positive and will not excee
d 1,000,000,000

Output

Output a single positive integer, telling the maximum number of diamonds that Bessie can showcase in
 total in both the cases.

Sample Input

7 3
10
5
1
12
9
5
14

Sample Output

5
题解:
先讲一下题意,大致说是将n个数选出几个数放入两个箱子中,一个箱中的最大数减最小数不得超过k,使得选出的数个数最大化。
首先这题有一个比较明显的特性:
两个箱子中放的数肯定是排完序后连续的一段,我们可以先将从第i个点出发的最大长度算出,在枚举分割点就行了(我是枚举起点的)
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
int n,m,i,r,a[50005],f[50005],g[50005],ans;
int main()
{
    scanf("%d%d",&n,&m);
    for(i=1;i<=n;i++)
        scanf("%d",&a[i]);
    sort(a+1,a+n+1);
    r=1;
    for(i=1;i<=n;i++)
    {
        while(a[r+1]-a[i]<=m&&r<n) r++;
        f[i]=r-i+1;
    }
    for(i=n;i>=1;i--)
        g[i]=max(g[i+1],f[i]);
    ans=0;
    for(i=1;i<=n;i++)
        ans=max(ans,f[i]+g[i+f[i]]);
    printf("%d",ans);
    return 0;
}

 

4582: [Usaco2016 Open]Diamond Collector

标签:

原文地址:http://www.cnblogs.com/lwq12138/p/5466863.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!