标签:
Fibonacci String
Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5358 Accepted Submission(s): 1819
Problem Description
After little Jim learned Fibonacci Number in the class , he was very interest in it.
Now he is thinking about a new thing -- Fibonacci String .
He defines : str[n] = str[n-1] + str[n-2] ( n > 1 )
He is so crazying that if someone gives him two strings str[0] and str[1], he will calculate the str[2],str[3],str[4] , str[5]....
For example :
If str[0] = "ab"; str[1] = "bc";
he will get the result , str[2]="abbc", str[3]="bcabbc" , str[4]="abbcbcabbc" …………;
As the string is too long ,Jim can‘t write down all the strings in paper. So he just want to know how many times each letter appears in Kth Fibonacci String . Can you help him ?
Input
The first line contains a integer N which indicates the number of test cases.
Then N cases follow.
In each case,there are two strings str[0], str[1] and a integer K (0 <= K < 50) which are separated by a blank.
The string in the input will only contains less than 30 low-case letters.
Output
For each case,you should count how many times each letter appears in the Kth Fibonacci String and print out them in the format "X:N".
If you still have some questions, look the sample output carefully.
Please output a blank line after each test case.
To make the problem easier, you can assume the result will in the range of int.
Sample Input
Sample Output
a:1
b:3
c:2
d:0
e:0
f:0
g:0
h:0
i:0
j:0
k:0
l:0
m:0
n:0
o:0
p:0
q:0
r:0
s:0
t:0
u:0
v:0
w:0
x:0
y:0
z:0
Author
linle
Source
题解:求第你n个斐波那契字符串的字母统计.....求出第n个斐波那契字符串再统计。
AC代码:
#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<cstdlib>
#include<iomanip>
#include<algorithm>
#include<time.h>
typedef long long LL;
using namespace std;
int main()
{
int t;
string s0,s1;
int n;
LL s[50]={0};
s[1]=1;
for(int i=2;i<50;i++)
{
s[i]=s[i-1]+s[i-2];
}
cin>>t;
while(t--)
{
cin>>s0>>s1>>n;
LL ch1[26]={0};
LL ch2[26]={0};
for(int i=0;i<s0.size();i++)
{
ch1[s0[i]-'a']++; //字符转换成数字
}
for(int i=0;i<s1.size();i++)
{
ch2[s1[i]-'a']++; //字符转换成数字
}
if(n==0)
{
for(int i=0;i<26;i++)
{
cout<<(char)('a'+i)<<":"<<ch1[i]<<endl; //n=0时,只输出第一个
}
cout<<endl; continue;
}
for(int i=0;i<26;i++)
{
cout<<(char)('a'+i)<<":"<<s[n-1]*ch1[i]+s[n]*ch2[i]<<endl; //累加到第n-1个和第n个
}
cout<<endl;
}
return 0;
}
HDU 1708 Fibonacci String(斐波那契字串)
标签:
原文地址:http://blog.csdn.net/liangzhaoyang1/article/details/51335195