码迷,mamicode.com
首页 > 其他好文 > 详细

What Are You Talking About

时间:2016-05-07 09:36:31      阅读:140      评论:0      收藏:0      [点我收藏+]

标签:

Description

Ignatius is so lucky that he met a Martian yesterday. But he didn‘t know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?
 

Input

The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian‘s language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian‘s language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can‘t find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(‘ ‘), tab(‘\t‘), enter(‘\n‘) and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that‘s also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.
 

Output

In this problem, you have to output the translation of the history book.
 

Sample Input

START from fiwo hello difh mars riwosf earth fnnvk like fiiwj END START difh, i‘m fiwo riwosf. i fiiwj fnnvk! END
 

Sample Output

hello, i‘m from mars. i like earth!

Hint

 Huge input, scanf is recommended. 


代码如下:

#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;
struct node{
	int count;
	char s[200];
	struct node *a[27];
	node(){
        count=0;
        memset(a,0,sizeof(a));
	}
};
struct node *k,*d;
char s[1001],s1[1001],s2[1001];
void insert(char c1[],char c2[]){
	d=k;
	int w=strlen(c1);
	for(int i=0;i<w;i++){
	    if(d->a[c1[i]-'a']==NULL)
	        d->a[c1[i]-'a']=new node;
	    d=d->a[c1[i]-'a'];
	}
	d->count=1;
	strcpy(d->s,c2);
}
char *find(char c1[]){
	d=k;
	int w=strlen(c1);
	for(int i=0;i<w;i++){
	    d=d->a[c1[i]-'a'];
	    if(d==0)return NULL;
	}
	if(d->count==0)return NULL;
	return d->s;
}
int l;
char z[2333];
int main(){
	scanf("%s",&s);
	k=new node;
	while(1){
		scanf("%s",&s1);
		if(strcmp(s1,"END")==0)break;
		scanf("%s",&s2);
		insert(s2,s1);
	}
	scanf("%s",&s);
	getchar();
	while(1){
		gets(s);
		if(strcmp(s,"END")==0)break;
		for(int i=0;i<strlen(s);i++){
			l=0;
		    while(s[i]>='a'&&s[i]<='z')
		        z[l++]=s[i++];
		    z[l]='\0';
		    char *ans=find(z);
		    if(ans==0)cout<<z;
		    else cout<<ans;
		    cout<<s[i];
		}
		cout<<endl;
	}
	return 0;
}

What Are You Talking About

标签:

原文地址:http://blog.csdn.net/qq_34215568/article/details/51332398

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!