码迷,mamicode.com
首页 > 其他好文 > 详细

习题三1004

时间:2016-05-07 09:48:00      阅读:102      评论:0      收藏:0      [点我收藏+]

标签:

Problem D

TimeLimit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K(Java/Other)
 

Problem Description

Anumber whose only prime factors are 2,3,5 or 7 is called a humble number. Thesequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27,... shows the first 20 humble numbers. <br><br>Write a program tofind and print the nth element in this sequence<br>

 

 

Input

Theinput consists of one or more test cases. Each test case consists of oneinteger n with 1 <= n <= 5842. Input is terminated by a value of zero (0)for n.<br>

 

 

Output

Foreach test case, print one line saying "The nth humble number isnumber.". Depending on the value of n, the correct suffix "st","nd", "rd", or "th" for the ordinal number nthhas to be used like it is shown in the sample output.<br>

 

 

Sample Input

1
2
3
4
11
12
13
21
22
23
100
1000
5842
0

 

 

Sample Output

The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.

 

 

题意:

符合要求的丑数只含有2357的质因子求前5842个丑数


解题思路:

humble number从1为"始祖",剩下的所有数,其实都是在此基础上乘以2,3,5,7演化出来的,:f[t]=min(2*f[i],3*f[j],5*f[k],7*f[l]); 


#include <iostream>
#include <stdio.h>
using namespace std;
int f[5843],n;
int i,j,k,l;

int min(int a,int b,int c,int d)
{
    int min=a;
    if(b<min) min=b;
    if(c<min) min=c;
    if(d<min) min=d;

    if(a==min) i++;
    if(b==min) j++;
    if(c==min) k++;
    if(d==min) l++;

    return min;
}

int main()
{
    i=j=k=l=1;
    f[1]=1;
    for(int t=2;t<=5842;t++)
    {
        f[t]=min(2*f[i],3*f[j],5*f[k],7*f[l]);
    }
    while(scanf("%d",&n)&&n!=0)
    {
        if(n%10==1&&n%100!=11)
            printf("The %dst humble number is %d.\n",n,f[n]);
        else if(n%10==2&&n%100!=12)
            printf("The %dnd humble number is %d.\n",n,f[n]);
        else if(n%10==3&&n%100!=13)
            printf("The %drd humble number is %d.\n",n,f[n]);
        else
            printf("The %dth humble number is %d.\n",n,f[n]);
    }

    return 1;
}



习题三1004

标签:

原文地址:http://blog.csdn.net/nero_z/article/details/51333540

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!