码迷,mamicode.com
首页 > 其他好文 > 详细

HDU2037

时间:2016-05-07 10:26:59      阅读:140      评论:0      收藏:0      [点我收藏+]

标签:

今年暑假不AC

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 44168    Accepted Submission(s): 23579


Problem Description
“今年暑假不AC?”
“是的。”
“那你干什么呢?”
“看世界杯呀,笨蛋!”
“@#$%^&*%...”

确实如此,世界杯来了,球迷的节日也来了,估计很多ACMer也会抛开电脑,奔向电视了。
作为球迷,一定想看尽量多的完整的比赛,当然,作为新时代的好青年,你一定还会看一些其它的节目,比如新闻联播(永远不要忘记关心国家大事)、非常6+7、超级女生,以及王小丫的《开心辞典》等等,假设你已经知道了所有你喜欢看的电视节目的转播时间表,你会合理安排吗?(目标是能看尽量多的完整节目)
 

Input
输入数据包含多个测试实例,每个测试实例的第一行只有一个整数n(n<=100),表示你喜欢看的节目的总数,然后是n行数据,每行包括两个数据Ti_s,Ti_e (1<=i<=n),分别表示第i个节目的开始和结束时间,为了简化问题,每个时间都用一个正整数表示。n=0表示输入结束,不做处理。
 

Output
对于每个测试实例,输出能完整看到的电视节目的个数,每个测试实例的输出占一行。
 

Sample Input
12 1 3 3 4 0 7 3 8 15 19 15 20 10 15 8 18 6 12 5 10 4 14 2 9 0
 

Sample Output
5


按照结束时间的先后进行排序,那么最晚结束的就在最后面,只要你的结束时间在我的开始时间前面那么数目就加1,这里需要注意的是输入是无序的。

#include <iostream>
#include <algorithm>
#include <stdio.h>
using namespace std;
int n;
struct Node {
    int s, e;
} nodes[101];

bool cmp(const Node & n1, const Node & n2) {
    return n1.e < n2.e;
}
int opt[101];
int main() {

    while(cin >> n, n) {
        for(int i=0; i<n; i++) {
            cin >> nodes[i].s >> nodes[i].e;
            opt[i] = 0;
        }
        sort(nodes, nodes+n, cmp);
        opt[0] = 1;
        for(int i=1; i<n; i++) {
            for(int j=i-1; j>=0; j--) {
                if(nodes[i].s >= nodes[j].e) {
                    opt[i] = opt[j]+1;
                    break;
                }
            }
            if(opt[i] < opt[i-1]) {
                opt[i] = opt[i-1];
                nodes[i].e = nodes[i-1].e;
            }
        }
        cout << opt[n-1] << endl;
    }

    return 0;
}


HDU2037

标签:

原文地址:http://blog.csdn.net/wzngzaixiaomantou/article/details/51332870

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!