码迷,mamicode.com
首页 > 其他好文 > 详细

数据结构实验之链表五:单链表的拆分

时间:2016-05-07 10:35:11      阅读:125      评论:0      收藏:0      [点我收藏+]

标签:

数据结构实验之链表五:单链表的拆分

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

输入N个整数顺序建立一个单链表,将该单链表拆分成两个子链表,第一个子链表存放了所有的偶数,第二个子链表存放了所有的奇数。两个子链表中数据的相对次序与原链表一致。

输入

第一行输入整数N;;
第二行依次输入N个整数。

输出

第一行分别输出偶数链表与奇数链表的元素个数; 
第二行依次输出偶数子链表的所有数据;
第三行依次输出奇数子链表的所有数据。

示例输入

10
1 3 22 8 15 999 9 44 6 1001

示例输出

4 6
22 8 44 6 
1 3 15 999 9 1001

提示

不得使用数组!
#include<stdio.h>
#include<stdlib.h>

typedef struct node
{
    int data;
    struct node *next;
} Node ;

Node *creatList(int n) //逆序建表,链表的初始化
{
    Node *head,*p;
    int i;
    head=(Node *)malloc(sizeof(Node ));
    head->next=NULL;
    for(i=0;i<n;i++)
    {
        p=(Node *)malloc(sizeof(Node ));
        scanf("%d",&p->data);
        p->next=head->next;
        head->next=p;
    }
    return head;

}

Node *split(Node *head1)//链表的拆分
{
    Node *head2,*p,*q;
    int cnt1=0,cnt2=0;
    head2=(Node *)malloc(sizeof(Node ));
    head2->next=NULL;
    p=head1->next;
    head1->next=NULL;
    q=p->next;
    while(p)
    {
        if(p->data%2==0)
        {
            p->next=head1->next;
            head1->next=p;
            cnt1++;
        }
        else
        {
            p->next=head2->next;
            head2->next=p;
            cnt2++;
        }
        p=q;
        if(q!=NULL)
            q=q->next;
    }
    printf("%d %d\n",cnt1,cnt2);
    return head2;
}

void Print(Node *head)//遍历链表
{
    Node *s;
    s=head->next;
    while(s)
    {
        if(s->next==NULL)
            printf("%d\n",s->data);
        else
            printf("%d ",s->data);
            s=s->next;
    }
}

void main()
{
    int n;
    Node *head1,*head2,*s;
    scanf("%d",&n);
    head1=creatList(n);
    head2=split(head1);
    Print(head1);
    Print(head2);
}


数据结构实验之链表五:单链表的拆分

标签:

原文地址:http://blog.csdn.net/lsmrsun/article/details/51331219

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!