码迷,mamicode.com
首页 > 其他好文 > 详细

Let Me Count The Ways

时间:2016-05-07 11:05:28      阅读:175      评论:0      收藏:0      [点我收藏+]

标签:

Description

技术分享

After making a purchase at a large department store, Mel‘s change was 17 cents. He received 1 dime, 1 nickel, and 2 pennies. Later that day, he was shopping at a convenience store. Again his change was 17 cents. This time he received 2 nickels and 7 pennies. He began to wonder ‘ "How many stores can I shop in and receive 17 cents change in a different configuration of coins? After a suitable mental struggle, he decided the answer was 6. He then challenged you to consider the general problem.

Write a program which will determine the number of different combinations of US coins (penny: 1c, nickel: 5c, dime: 10c, quarter: 25c, half-dollar: 50c) which may be used to produce a given amount of money.

Input

The input will consist of a set of numbers between 0 and 30000 inclusive, one per line in the input file.

Output

The output will consist of the appropriate statement from the selection below on a single line in the output file for each input value. The number m is the number your program computes, n is the input value.

There are mways to produce ncents change.

There is only 1 way to produce ncents change.

Sample input

17 
11
4

Sample output

There are 6 ways to produce 17 cents change. 
There are 4 ways to produce 11 cents change. 
There is only 1 way to produce 4 cents change.
题目大意:

       就是给你一个数,分别用1 5 10 25 50 相加有多少种方法可以加到这个数。

思路:

       一个简单的完全背包问题,每种物品有无限件,还是根据01背包改变下次次序就可以。注意输出,这个是个坑。

当数为0的时候输出的也是1。

代码:

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <queue>
#include <map>
#include <cmath>
#include <string>
#define INF 0x3f3f3f3f
using namespace std;

int main()
{
    int coin[5] = {1, 5, 10, 25, 50},i,j,n;
    long long dp[30010];
    while(scanf("%d",&n) != EOF)
    {
        for(i = 1; i <= n; i++)
            dp[i] = 1;
        dp[0] = 1;
        for(i = 1; i < 5; i++)
        {

            for(j = coin[i]; j <= n; j++)
            {
                dp[j] = dp[j - coin[i]] + dp[j];
            }
        }
        if(dp[n] !=  1)
            printf("There are %lld ways to produce %d cents change.\n",dp[n],n);
        else
            printf("There is only %lld way to produce %d cents change.\n",dp[n],n);
    }
    return 0;
}




Let Me Count The Ways

标签:

原文地址:http://blog.csdn.net/bmamb/article/details/51332810

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!