码迷,mamicode.com
首页 > 其他好文 > 详细

【hdu1247】Hat’s Words

时间:2016-05-07 18:05:15      阅读:147      评论:0      收藏:0      [点我收藏+]

标签:

Description

A hat’s word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.
You are to find all the hat’s words in a dictionary.

Input

Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 50,000 words.
Only one case.

Output

Your output should contain all the hat’s words, one per line, in alphabetical order.

Sample Input

a
ahat
hat
hatword
hziee
word

Sample Output

ahat
hatword

Author

戴帽子的

题解

题目意思:给一堆串,判断哪个串可以又这堆串里的两个串相连得到

trie树。把串先读进去,然后枚举每种可能判断一下。

s.substr (i,j) 串s 从i开始截取j位

next要开27个。(0里边是空的)

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
struct node
{
    int next[27];
    int w;
}t[50010];
string ss[50010];
string s;
int topt,cnt;
void add_trie()
{
    int l=s.length(),now = 0;
    for (int i=0;i<l;i++)
    {
        int x = s[i]-a+1;
        if (t[now].next[x])
            now = t[now].next[x];
        else 
        {
            t[now].next[x] = ++topt;
            now = topt;
        }
    }
    t[now].w=1;
}
int find()
{
    int l=s.length(),now = 0,p = 0;
    while (p<l)
    {
        if (!t[now].next[s[p]-a+1]) return 0;
        else
        {
            now = t[now].next[s[p]-a+1];
            p++;
        }
    }
    if (t[now].w) return 1;
        else return 0;
}
int main()
{
    while (cin>>ss[++cnt])
    {
        s = ss[cnt];
        add_trie();
    }
    for (int i=1;i<cnt;i++)
    {
        string s3=ss[i];
        int l=s3.length();
        for (int j=1;j<l;j++)
        {
            s=s3.substr(0,j);
            if (find())
            {
                s = s3.substr(j,l);
                if (find())
                {
                    cout<<s3<<endl;
                    break;
                }
            }
        }
    }    
}

 

 

【hdu1247】Hat’s Words

标签:

原文地址:http://www.cnblogs.com/liumengyue/p/5468784.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!