码迷,mamicode.com
首页 > 其他好文 > 详细

POJ1001:Exponentiation

时间:2016-05-12 12:37:01      阅读:136      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit:500ms Memory Limit:10000K

Description

Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. 
This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.

Input

The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

Output

The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don‘t print the decimal point if the result is an integer.

Sample Input

Sample Input

95.123 12
0.4321 20
5.1234 15
6.7592  9
98.999 10
1.0100 12

Sample Output

548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201

在计算机上进行高精度计算,首先要处理好以下几个基本问题:

  1. 数据的接收与存储;
  2. 计算结果位数的确定;
  3. 进位处理和借位处理;
  4. 商和余数的求法; 
输入和存储

运算因子超出了整型、实型能表示的范围,肯定不能直接用一个数的形式来表示。能表示多个数的数据类型有两种:数组和字符串。

  1. 数组:每个数组元素存储1位(在优化时,这里是一个重点!),有多少位就需要多少个数组元素;优点:每一位都是数的形式,可以直接加减;运算时非常方便.缺点:数组不能直接输入;输入时每两位数之间必须有分隔符,不符合数值的输入习惯;优点:每一位都是数的形式,可以直接加减;运算时非常方便.缺点:数组不能直接输入;输入时每两位数之间必须有分隔符,不符合数值的输入习惯;
  2. 字符串:字符串的最大长度是255,可以表示255位。优点:能直接输入输出,输入时,每两位数之间不必分隔符,符合数值优化:n一个数组元素存放四位数注意:是加减法时可以用interger,但是当是乘法的时候,就要用int64,否则会出现越界的情况。

    还有就是:输出时对非最高位的补零处理。


#include<iostream>
using namespace std;
#define max 200

int main()
{
	int a[max]={0},n,e,j,k,q,set=0;//base的n次方
	char c[20];//接收输入字符串
	while(cin>>c>>n)
	{
		int len=strlen(c),base=0,i,record=0;
		for(i=0;i<len;i++)
		{
			if(c[i]==‘.‘) 
			{
				record=len-i-1;//record为小数的位数
				continue;
			}
			 base=base*10+c[i]-‘0‘;
		}
		if(record)
		{
			for(k=len-1;c[k]==‘0‘;k--,record--)
			base/=10;//去掉后面多余的0;
		}
		record*=n;//record为总的小数位

		for(q=base,i=0;i<max;i++,q/=10)
		{
			a[i]=q%10;//把base复制到数组a
			
		}
		
		for(j=0;j<n-1;j++)
		{
			for(i=0;i<max;i++)
			{
				a[i]=a[i]*base+set;
				set=a[i]/10;
				a[i]=a[i]%10;
			}
		}//计算,结果保存在数组a中
		
		for(i=max-1;i>=0;i--)//i是首个不为0的
				if(a[i]!=0) break;
			
			if(record>i)//无整数部分
			{
				cout<<".";
				for(e=record-1;e>=0;e--)
				{
					cout<<a[e];
				}
			}
			else //有整数部分
			{
				for(;i>record-1;i--)
				{
					cout<<a[i];
				}
				if(i>=0)	
					cout<<".";				
				for(;i>=0;i--)
					cout<<a[i];
			}
		cout<<endl;
	}
	return 0;
}


技术分享



POJ1001:Exponentiation

标签:

原文地址:http://blog.csdn.net/songzitea/article/details/51340106

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!