码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1384 Piggy-Bank 完全背包

时间:2014-07-31 17:01:57      阅读:248      评论:0      收藏:0      [点我收藏+]

标签:acm   动态规划   poj   背包   

题目链接:POJ 1384 Piggy-Bank

Piggy-Bank
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 7880   Accepted: 3801

Description

Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid. 

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs! 

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it‘s weight in grams.

Output

Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".

Sample Input

3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4

Sample Output

The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.

Source

题意:给你一个储蓄罐空的,和满的重量,然后给出各种硬币的价值和对应的重量,要你估计出储蓄罐里面硬币价值和最小为多少,注意要保证重量和恰好为给出满的重量。

思路:完全背包问题,只是求最小值,注意初始化的处理就可以。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

#define INF 0xffffff
int n, dp[10010];
int main()
{
    int t, e, f, p, w;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d%d", &e, &f);
        scanf("%d", &n);
        for(int i = 0; i <= f-e; i++)
            dp[i] = INF;
        dp[0] = 0;
        while(n--)
        {
            scanf("%d%d", &p, &w);
            for(int i = w; i <= f-e; i++)
                dp[i] = min(dp[i], dp[i-w]+p);
        }
        if(dp[f-e] == INF)
            printf("This is impossible.\n");
        else
            printf("The minimum amount of money in the piggy-bank is %d.\n", dp[f-e]);
    }
    return 0;
}

POJ 1384 Piggy-Bank 完全背包,布布扣,bubuko.com

POJ 1384 Piggy-Bank 完全背包

标签:acm   动态规划   poj   背包   

原文地址:http://blog.csdn.net/u011439796/article/details/38318791

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!