码迷,mamicode.com
首页 > 其他好文 > 详细

poj2739 Sum of Consecutive Prime Numbers (素数打表)

时间:2016-05-12 14:24:22      阅读:161      评论:0      收藏:0      [点我收藏+]

标签:

D - Sum of Consecutive Prime Numbers
Crawling in process... Crawling failed Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Appoint description:

Description

Some positive integers can be represented by a sum of one or more consecutive prime numbers. How many such representations does a given positive integer have? For example, the integer 53 has two representations 5 + 7 + 11 + 13 + 17 and 53. The integer 41 has three representations 2+3+5+7+11+13, 11+13+17, and 41. The integer 3 has only one representation, which is 3. The integer 20 has no such representations. Note that summands must be consecutive prime
numbers, so neither 7 + 13 nor 3 + 5 + 5 + 7 is a valid representation for the integer 20.
Your mission is to write a program that reports the number of representations for the given positive integer.

Input

The input is a sequence of positive integers each in a separate line. The integers are between 2 and 10 000, inclusive. The end of the input is indicated by a zero.

Output

The output should be composed of lines each corresponding to an input line except the last zero. An output line includes the number of representations for the input integer as the sum of one or more consecutive prime numbers. No other characters should be inserted in the output.

Sample Input

2
3
17
41
20
666
12
53
0

Sample Output

1
1
2
3
0
0
1
2

判断某个数 能不能由连续的素数相加得到。如果能 最多能有几个

#include <stdio.h>
#include <math.h>
bool prim[10000+20];
int main()
{
	prim[2]=prim[1]=false;
	for(int i=2;i<sqrt(10000+10);i++)
	{
		if(!prim[i])
		{
			for(int j=2*i;j<10000+10;j+=i)
			{
				prim[j]=true;
			}
		}
	}
	int n;
	while(~scanf("%d",&n)&&n)
	{
		int count=0;
		for(int j=2;j<=n;j++)
		{
			int sum=0;
			if(!prim[j])
			for(int k=j;k<=n;k++)
			{
				if(!prim[k])
				{
					sum+=k;
				//	printf("%d ",sum);
				}
				if(sum>n)
				break;
				if(sum==n)
				{
					count++;
					break;
				}
			}
		}
		printf("%d\n",count);
	}
}


poj2739 Sum of Consecutive Prime Numbers (素数打表)

标签:

原文地址:http://blog.csdn.net/su20145104009/article/details/51360332

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!