码迷,mamicode.com
首页 > 其他好文 > 详细

The Castle

时间:2016-05-12 15:22:59      阅读:154      评论:0      收藏:0      [点我收藏+]

标签:

Description

     1   2   3   4   5   6   7 
   #############################

 1 #   |   #   |   #   |   |   #

   #####---#####---#---#####---#

 2 #   #   |   #   #   #   #   #

   #---#####---#####---#####---#

 3 #   |   |   #   #   #   #   #

   #---#########---#####---#---#

 4 #   #   |   |   |   |   #   #

   #############################

(Figure 1)


#  = Wall 
|  = No wall 
-  = No wall

Figure 1 shows the map of a castle.Write a program that calculates 
1. how many rooms the castle has 
2. how big the largest room is 
The castle is divided into m * n (m<=50, n<=50) square modules. Each such module can have between zero and four walls. 

Input

Your program is to read from standard input. The first line contains the number of modules in the north-south direction and the number of modules in the east-west direction. In the following lines each module is described by a number (0 <= p <= 15). This number is the sum of: 1 (= wall to the west), 2 (= wall to the north), 4 (= wall to the east), 8 (= wall to the south). Inner walls are defined twice; a wall to the south in module 1,1 is also indicated as a wall to the north in module 2,1. The castle always has at least two rooms.

Output

Your program is to write to standard output: First the number of rooms, then the area of the largest room (counted in modules).

Sample Input

4
7
11 6 11 6 3 10 6
7 9 6 13 5 15 5
1 10 12 7 13 7 5
13 11 10 8 10 12 13

Sample Output

5
9
#include<iostream>
using namespace std;
int a[1001][1001],p[1001][1001],d,i,j,maxm,ans,n,m;
void dfs(int x,int y){
	p[x][y]=1;
	d++;
	if(a[x][y]>=8)
	    a[x][y]-=8;
	else 
	    if(p[x+1][y]==0)dfs(x+1,y);
	if(a[x][y]>=4)
	    a[x][y]-=4;
	else 
	    if(p[x][y+1]==0)dfs(x,y+1);
	if(a[x][y]>=2)
	    a[x][y]-=2;
	else 
	    if(p[x-1][y]==0)dfs(x-1,y);
	if(a[x][y]>=1)
	    a[x][y]-=1;
	else 
	    if(p[x][y-1]==0)dfs(x,y-1);
}
int main(){
	cin>>n>>m;
	for(i=1;i<=n;i++)
	    for(j=1;j<=m;j++)
	        cin>>a[i][j];
	for(i=1;i<=n;i++)
	    for(j=1;j<=m;j++)
	        if(p[i][j]==0){
	        	d=0;
	        	dfs(i,j);
	        	ans++;
	        	if(d>maxm)maxm=d;
			}
	cout<<ans<<endl<<maxm;
	return 0;
}

dfs搞定,只要连在一起就算一个房间,一个深搜连时限都不用管

The Castle

标签:

原文地址:http://blog.csdn.net/qq_34215568/article/details/51364043

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!