码迷,mamicode.com
首页 > 其他好文 > 详细

HDU3336 Count the string

时间:2016-05-12 15:26:09      阅读:156      评论:0      收藏:0      [点我收藏+]

标签:

题目链接:HDU3336

Count the string

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7642    Accepted Submission(s): 3553


Problem Description
It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: "abab"
The prefixes are: "a", "ab", "aba", "abab"
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.
 

Input
The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.
 

Output
For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.
 

Sample Input
1 4 abab
 

Sample Output
6
 

题意:给出一个字符串s,对于s[1....i]的子串(i从1到最大)一共在s中出现了几次,可以重叠。

题目分析:KMP+DP,首先求出s的next数组,这里next数组应该只能使用未优化的标准求法,因为这里nexts数组储存的是最长的公共前缀与后缀,我们设一个数组dp,dp[i]代表以i结尾的字符串与前缀相同的子串的个数,比如题目中abab对应的dp数组应为1122,其中aba包含a和aba,abab包含abab和ab。具体递推公式为dp[i]=dp[nexts[i]]+1,然后这题的答案就是把dp数组中的所有数加起来了。

//
//  main.cpp
//  HDU3336(1)
//
//  Created by teddywang on 16/5/4.
//  Copyright © 2016年 teddywang. All rights reserved.
//

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int N,n,nexts[200010],sum,dp[200010];
char s[200010];

void getnext()
{
    int i=0,j=-1;
    nexts[0]=-1;
    while(i<n)
    {
        if(j==-1||s[i]==s[j])
        {
            nexts[++i]=++j;
            dp[i]=dp[nexts[i]]+1;
        }
        else j=nexts[j];
    }
}

int main()
{
    cin>>N;
    while(N--)
    {
        cin>>n;
        scanf("%s",s);
        getnext();
        sum=0;
        for(int i=1;i<=n;i++)
        {
            sum+=dp[i];
            sum%=10007;
        }
        printf("%d\n",sum);
    }
}


HDU3336 Count the string

标签:

原文地址:http://blog.csdn.net/qq_29480875/article/details/51335555

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!