码迷,mamicode.com
首页 > 其他好文 > 详细

AYITACM2016省赛第四周D-Gunner(STL,map)

时间:2016-05-12 16:31:42      阅读:165      评论:0      收藏:0      [点我收藏+]

标签:

Description

Long long ago, there is a gunner whose name is Jack. He likes to go hunting very much. One day he go to the grove. There are $n$ birds and $n$ trees. The $i-th$ bird stands on the top of the $i-th$ tree. The trees stand in straight line from left to the right. Every tree has its height. Jack stands on the left side of the left most tree. When Jack shots a bullet in height H to the right, the bird which stands in the tree with height $H$ will falls. 
Jack will shot many times, he wants to know how many birds fall during each shot. 

a bullet can hit many birds, as long as they stand on the top of the tree with height of $H$.
 

Input

There are multiple test cases (about 5), every case gives $n,m$ in the first line, $n$ indicates there are $n$ trees and $n$ birds, $m$ means Jack will shot $m$ times. 

In the second line, there are $n$ numbers $h[1],h[2],h[3],…,h[n]$ which describes the height of the trees. 

In the third line, there are m numbers $q[1],q[2],q[3],…,q[m]$ which describes the height of the Jack’s shots. 

Please process to the end of file. 

[Technical Specification] 

$1 \leq n,m \leq 1000000(10^{6})$ 

$1 \leq h[i],q[i] \leq 1000000000(10^{9})$ 

All inputs are integers.
 

Output

For each $q[i]$, output an integer in a single line indicates the number of birds Jack shot down.
 

Sample Input

4 3 1 2 3 4 1 1 4
 

Sample Output

1 0 1

Hint

Huge input, fast IO is recommended. 
         
 

分析:

刚开始以为可以模拟,但题目所给范围那么的大,用long long 肯定超时,仔细读题就会明白其实就是统计每个高度出现的次数,而map容器最擅长的就是统计次数,还能避免时间超限,然后用erase()清空容器;

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<map>
using namespace std;
int main()
{
    int m,n,i,j,k;
    while(scanf("%d%d",&m,&n)!=EOF)
    {
        map<int ,int>M; //定义map容器,主要是对应关系
        for(i=0; i<m; i++)
        {
            scanf("%d",&k);//输入value值
            M[k]++;//统计key值
        }
        for(i=0; i<n; i++)
        {
            scanf("%d",&k);
            if(M[k])
            {
                printf("%d\n",M[k]);//输出key值
                M.erase(k);  //清空value值
            }
            else
                printf("0\n");
        }
    }
    return 0;
}


AYITACM2016省赛第四周D-Gunner(STL,map)

标签:

原文地址:http://blog.csdn.net/linyuxilu/article/details/51360821

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!