码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1753 Flip Game

时间:2016-05-12 16:35:23      阅读:132      评论:0      收藏:0      [点我收藏+]

标签:

Flip Game
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 38720   Accepted: 16818

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it‘s black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 
  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

技术分享Consider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it‘s impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

Source



这道题要注意到两个关键点;
1、对于一个方案来说,棋子翻动的先后顺序并不影响结果;
2、对于同一枚棋子,只有两种状态,翻或者不翻;

接着就可以搜索解决问题了;

#include <iostream>
#include <string>
#include <cstring>
#include <string>
#include <algorithm>
#include <cstdio>

using namespace std;
int ans;
char maze[5][5];
bool judge()
{
    bool flag=1;
    for(int i=0;i<4;++i)
    {
        for(int j=0;j<4;++j)
        {
            if(i==0&&j==0)
            {
                continue;
            }
            if(j!=0)
            {
                if(maze[i][j]!=maze[i][j-1])
                {
                    flag=0;
                    break;
                }
            }
            else if(j==0)
            {
                if(maze[i][j]!=maze[i-1][3])
                {
                    flag=0;
                    break;
                }
            }
        }
        if(!flag)
            break;
    }
    return flag;
}
void iswap(int x,int y)
{
    if(maze[x][y]=='b')
    {
        maze[x][y]='w';
    }
    else if(maze[x][y]=='w')
    {
        maze[x][y]='b';
    }
}
void change(int x,int y)
{
    iswap(x,y);
    if(x-1>=0)
    {
        iswap(x-1,y);
    }
    if(x+1<4)
    {
        iswap(x+1,y);
    }
    if(y-1>=0)
    {
        iswap(x,y-1);
    }
    if(y+1<4)
    {
        iswap(x,y+1);
    }
}
void dfs(int x,int y,int step)
{
    if(judge())
    {
        if(step<ans)
        {
            ans=step;
            //cout<<x<<" "<<y<<" "<<step<<endl;
        }
        return ;
    }
    change(x,y);
    int dx=x,dy=y+1;
    if(dy>=4)
    {
        dx+=1;
        dy=0;
    }
    if(dx>=4)
    {
        if(judge())
        {
            if(step+1<ans)
            {
                ans=step+1;
            }
        }
        change(x,y);
        return ;
    }
    dfs(dx,dy,step+1);
    change(x,y);
    dfs(dx,dy,step);
    return ;
}
int main()
{
    for(int i=0;i<4;++i)
    {
        scanf("%s",&maze[i]);
    }
    ans=20;
    dfs(0,0,0);
    /*for(int i=0;i<4;++i)
    {
        printf("%s\n",maze[i]);
    }*/
    if(ans<20)
    {
        printf("%d\n",ans);
    }
    else
    {
        printf("Impossible\n");
    }
    return 0;
}


poj 1753 Flip Game

标签:

原文地址:http://blog.csdn.net/leeholmes/article/details/51361646

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!