码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1979 Red and Black -- dfs

时间:2016-05-12 16:36:23      阅读:169      评论:0      收藏:0      [点我收藏+]

标签:

Red and Black
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 29614   Accepted: 16095

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can‘t move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

‘.‘ - a black tile 
‘#‘ - a red tile 
‘@‘ - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

题意是从@点出发,然后遍历整个图,‘.’表示可以到达的地方,求最多可以走多少个‘.’,初始的点也算一个,注意sum=1初始化

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
char map[25][25];
int vis[25][25];
int n,m,num;
int dr[4]={0,1,-1,0};
int dc[4]={-1,0,0,1};
void dfs(int x,int y){
	int i;
	for(i=0;i<4;i++){
		int dx=x+dr[i];
		int dy=y+dc[i];
		if(dx>=0&&dx<n&&dy>=0&&dy<m&&!vis[dx][dy]&&map[dx][dy]=='.'){
			vis[dx][dy]=1;
			num++;
			dfs(dx,dy);
		}
	}
}
int main(){
	int i,j,x,y;
	//freopen("test.txt","r",stdin);
	while(~scanf("%d %d",&m,&n)){
		if(m==0&&n==0)
			break;
		char c[25];
		for(i=0;i<n;i++){
			scanf("%s",&c);
			for(j=0;j<m;j++){
				map[i][j]=c[j];
				if(map[i][j]=='@'){
					x=i;y=j;
				}
			}
		}
		//printf("%d %d\n",x,y);
		memset(vis,0,sizeof(vis));
		num=1;
		dfs(x,y);
		printf("%d\n",num);
	}
	return 0;
}


poj 1979 Red and Black -- dfs

标签:

原文地址:http://blog.csdn.net/qq_27717967/article/details/51365344

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!