标签:
2060: [Usaco2010 Nov]Visiting Cows 拜访奶牛
Time Limit: 3 Sec Memory Limit: 64 MB
Submit: 350 Solved: 256
[Submit][Status][Discuss]
Description
经过了几周的辛苦工作,贝茜终于迎来了一个假期.作为奶牛群中最会社交的牛,她希望去拜访N(1<=N<=50000)个朋友.这些朋友被标号为1..N.这些奶牛有一个不同寻常的交通系统,里面有N-1条路,每条路连接了一对编号为C1和C2的奶牛(1 <= C1 <= N; 1 <= C2 <= N; C1<>C2).这样,在每一对奶牛之间都有一条唯一的通路. FJ希望贝茜尽快的回到农场.于是,他就指示贝茜,如果对于一条路直接相连的两个奶牛,贝茜只能拜访其中的一个.当然,贝茜希望她的假期越长越好,所以她想知道她可以拜访的奶牛的最大数目.
Input
第1行:单独的一个整数N 第2..N行:每一行两个整数,代表了一条路的C1和C2.
Output
单独的一个整数,代表了贝茜可以拜访的奶牛的最大数目.
Sample Input
7
6 2
3 4
2 3
1 2
7 6
5 6
INPUT DETAILS:
Bessie knows 7 cows. Cows 6 and 2 are directly connected by a road,
as are cows 3 and 4, cows 2 and 3, etc. The illustration below depicts the
roads that connect the cows:
1--2--3--4
|
5--6--7
Sample Output
4
OUTPUT DETAILS:
Bessie can visit four cows. The best combinations include two cows
on the top row and two on the bottom. She can‘t visit cow 6 since
that would preclude visiting cows 5 and 7; thus she visits 5 and
7. She can also visit two cows on the top row: {1,3}, {1,4}, or
{2,4}.
HINT
Source
[Submit][Status][Discuss]
【题解】【简单的树型dp】
【以f[i][0]表示不选当前点,f[i][1]表示选择当前点。递归dp】
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int a[1000010],next[1000010],p[50010],tot;
int f[50010][2];
int n,ans;
inline void add(int x,int y)
{
tot++; a[tot]=y; next[tot]=p[x]; p[x]=tot;
tot++; a[tot]=x; next[tot]=p[y]; p[y]=tot;
return;
}
inline void dp(int x,int fa)
{
bool b=false;
int u=p[x];
while(u!=0)
{
if(a[u]!=fa)
{
b=true;
dp(a[u],x);
f[x][1]+=f[a[u]][0];//因为当前点选了,所以他的儿子不能被选
f[x][0]+=max(f[a[u]][0],f[a[u]][1]);//因为不选当前点,所以他的儿子可选可不选
}
u=next[u];
}
return;
}
int main()
{
int i,j;
scanf("%d",&n);
for(i=1;i<n;++i)
{
int x,y;
scanf("%d%d",&x,&y);
add(x,y);
}
for(i=1;i<=n;++i) f[i][1]=1;
dp(1,0);
ans=max(f[1][0],f[1][1]);
printf("%d\n",ans);
return 0;
}
【bzoj 2060】[Usaco2010 Nov]Visiting Cows 拜访奶牛
标签:
原文地址:http://blog.csdn.net/reverie_mjp/article/details/51363077