码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1003 Max Sum

时间:2016-05-12 19:11:03      阅读:195      评论:0      收藏:0      [点我收藏+]

标签:

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 208486    Accepted Submission(s): 48797


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
Case 1: 14 1 4 Case 2: 7 1 6
 

Author
Ignatius.L

细心+认真+恒心

#include<stdio.h>
#include<string.h>
#define max(a,b) a>b?a:b
int a[100005],d[100005];
int main(){
	int t,n,ant=1;
	int i,j1,j2,maxx;
	scanf("%d",&t);
	while(t--){
		memset(d,0,sizeof(d));
		scanf("%d",&n);	
		for( i=1;i<=n;i++)
			scanf("%d",&a[i]);
		maxx=d[1]=a[1]; //初始值 
		j1=j2=1;	//初始位置 
		for( i=2;i<=n;i++){
			d[i]=max(a[i],d[i-1]+a[i]);	//当前值与和比较,较大的放入d中 
			if(maxx<d[i]) {maxx=d[i];j2=i;}		//找出最大的和,并记录位置		
		}
		for( i=2;i<=j2;i++)
			if(d[i-1]<0) j1=i;//找出最大和位置前,最后一次改变开始值的位置 
		if(t==0) printf("Case %d:\n%d %d %d\n",ant++,maxx,j1,j2);	 
		 else printf("Case %d:\n%d %d %d\n\n",ant++,maxx,j1,j2);
	}
	return 0;
}





hdu 1003 Max Sum

标签:

原文地址:http://blog.csdn.net/z_huing/article/details/51354950

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!