码迷,mamicode.com
首页 > 其他好文 > 详细

CodeForces - 670C Cinema (map&模拟)水

时间:2016-05-12 20:14:10      阅读:163      评论:0      收藏:0      [点我收藏+]

标签:

CodeForces - 670C
Time Limit: 2000MS   Memory Limit: 262144KB   64bit IO Format: %I64d & %I64u

Status

Description

Moscow is hosting a major international conference, which is attended by n scientists from different countries. Each of the scientists knows exactly one language. For convenience, we enumerate all languages of the world with integers from 1 to 109.

In the evening after the conference, all n scientists decided to go to the cinema. There are m movies in the cinema they came to. Each of the movies is characterized by two distinct numbers — the index of audio language and the index of subtitles language. The scientist, who came to the movie, will be very pleased if he knows the audio language of the movie, will be almost satisfied if he knows the language of subtitles and will be not satisfied if he does not know neither one nor the other (note that the audio language and the subtitles language for each movie are always different).

Scientists decided to go together to the same movie. You have to help them choose the movie, such that the number of very pleased scientists is maximum possible. If there are several such movies, select among them one that will maximize the number of almost satisfied scientists.

Input

The first line of the input contains a positive integer n (1?≤?n?≤?200?000) — the number of scientists.

The second line contains n positive integers a1,?a2,?...,?an (1?≤?ai?≤?109), where ai is the index of a language, which the i-th scientist knows.

The third line contains a positive integer m (1?≤?m?≤?200?000) — the number of movies in the cinema.

The fourth line contains m positive integers b1,?b2,?...,?bm (1?≤?bj?≤?109), where bj is the index of the audio language of the j-th movie.

The fifth line contains m positive integers c1,?c2,?...,?cm (1?≤?cj?≤?109), where cj is the index of subtitles language of the j-th movie.

It is guaranteed that audio languages and subtitles language are different for each movie, that is bj?≠?cj.

Output

Print the single integer — the index of a movie to which scientists should go. After viewing this movie the number of very pleased scientists should be maximum possible. If in the cinema there are several such movies, you need to choose among them one, after viewing which there will be the maximum possible number of almost satisfied scientists.

If there are several possible answers print any of them.

Sample Input

Input
3
2 3 2
2
3 2
2 3
Output
2
Input
6
6 3 1 1 3 7
5
1 2 3 4 5
2 3 4 5 1
Output
1

Sample Output

Hint

Source

//题意:
有n个外国朋友来中国看电影,他们每个人只会一种语言(不同编号表不同语言示),现在有m部电影,每部电影的声音是a[i],字幕是b[i]。
如果电影的声音他懂的话,他会非常满意,如果字母他能看懂的话他会比较满意,否则它很不满意。
现在问看哪部电影会使得n个外国友人满意最高(如果两部电影使得n个外国友人非常满意的人数相同时,选比较满意的最多的那部电影)。
//思路:
因为a[i],b[i]很大,所以得用map来存,然后就是计数模拟比较找到最优解就行了。
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<map>
#define N 200010
using namespace std;
map<int,int>s;
int a[N];
int b[N];
struct zz
{
	int a;
	int b;
}p[N];
int main()
{
	int n,m,i,j,k;
	scanf("%d",&n);
	for(i=0;i<n;i++)
	{
		scanf("%d",&a[i]);
		s[a[i]]++;
	}
	scanf("%d",&m);
	for(i=1;i<=m;i++)
		scanf("%d",&p[i].a);
	for(i=1;i<=m;i++)
		scanf("%d",&p[i].b);
	int mm=0;k=1;
	for(i=1;i<=m;i++)
	{
		if(mm<s[p[i].a])
		{
			mm=s[p[i].a];
			k=i;
		}
	}
	int kk=0;
	for(i=1;i<=m;i++)
	{
		if(s[p[i].a]==mm)
		{
			if(kk<s[p[i].b])
			{
				kk=s[p[i].b];
				k=i;
			}
		}
	}
	printf("%d\n",k);
	return 0;
} 


CodeForces - 670C Cinema (map&模拟)水

标签:

原文地址:http://blog.csdn.net/yanghui07216/article/details/51356817

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!