码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3352 Road Construction

时间:2016-05-12 20:32:10      阅读:196      评论:0      收藏:0      [点我收藏+]

标签:

Road Construction
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 10648   Accepted: 5266

Description

It‘s almost summer time, and that means that it‘s almost summer construction time! This year, the good people who are in charge of the roads on the tropical island paradise of Remote Island would like to repair and upgrade the various roads that lead between the various tourist attractions on the island.

The roads themselves are also rather interesting. Due to the strange customs of the island, the roads are arranged so that they never meet at intersections, but rather pass over or under each other using bridges and tunnels. In this way, each road runs between two specific tourist attractions, so that the tourists do not become irreparably lost.

Unfortunately, given the nature of the repairs and upgrades needed on each road, when the construction company works on a particular road, it is unusable in either direction. This could cause a problem if it becomes impossible to travel between two tourist attractions, even if the construction company works on only one road at any particular time.

So, the Road Department of Remote Island has decided to call upon your consulting services to help remedy this problem. It has been decided that new roads will have to be built between the various attractions in such a way that in the final configuration, if any one road is undergoing construction, it would still be possible to travel between any two tourist attractions using the remaining roads. Your task is to find the minimum number of new roads necessary.

Input

The first line of input will consist of positive integers n and r, separated by a space, where 3 ≤ n ≤ 1000 is the number of tourist attractions on the island, and 2 ≤ r ≤ 1000 is the number of roads. The tourist attractions are conveniently labelled from 1 to n. Each of the following r lines will consist of two integers, v and w, separated by a space, indicating that a road exists between the attractions labelled v and w. Note that you may travel in either direction down each road, and any pair of tourist attractions will have at most one road directly between them. Also, you are assured that in the current configuration, it is possible to travel between any two tourist attractions.

Output

One line, consisting of an integer, which gives the minimum number of roads that we need to add.

Sample Input

Sample Input 1
10 12
1 2
1 3
1 4
2 5
2 6
5 6
3 7
3 8
7 8
4 9
4 10
9 10

Sample Input 2
3 3
1 2
2 3
1 3

Sample Output

Output for Sample Input 1
2

Output for Sample Input 2
0


题意:给一个n个点m条边的无向图,问最少需要添加几条边才能将图上 任意2个点 在 删除任意一条边 后还能互相到达(把一个图变成边双联通的最少需要添加几条边)。

首先学到一个常识,就是将一棵树变为变为边双联通最少需要添加(叶子节点数量+1)/2  。手画下应该能理解。

然后 边双联通定义:任意两点至少存在两条“边不重复”的路径,那么这个图就是边双联通的。

回到这个题,这个题的解题思路就是把这个图进行缩点,剩下的边(桥)构成一棵树,然后这计算这棵树的叶子节点的数量,套那个公式就行了。

叶子节点的特点是度为1。

具体方法是利用Tarjan对标记好dfn和low。对于每个点,它连接的点如果low值和它本身不一样,则度数+1(缩点计算度数)。然后对度数为1的进行计数就行了。


对了,这道题在POJ 的数据有点水,我开始瞎写了一发,过了。然后看别人题解,感觉哪里不对,产生一种幻觉我能hack,造了一组数据,居然把自己hack了。所以建议在那个题面下面的discuss里面找点数据数据自己测试一下。

这是我自己造的数据
8 9
1 2
2 3
3 4
4 2
3 5
5 6
6 7
7 5
7 8
应该输出1,然而之前自己写的代码输出了2。

然后可以去看看POJ的3177,跟这个题基本上一模一样。我下面这个直接提交会WA,看了dicuss,说有重边。后面过了,按照过的这个代码,重边的意思就是2个点之间只能有一条边,不可能在两个点之间形成环。所以我这个用邻接表写的会WA,用邻接矩阵的标记一下去重边就行了。

下面是我看了别人的题解过后写的
CODE
#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>

using namespace std;

const int N = 10000+10;

struct node      ///邻接表
{
    int en;
    int next;
}E[N];
int n,m;
int top;         ///邻接表边序号
int dfs_clock;   ///时间戳
int dfn[N];      ///到达第一次每个点的时间
int low[N];      ///当前点能追溯到的最早节点编号
int head[N];     ///邻接表头结点
int degree[N];   ///标记强联通分量之后每个结点的度

void Init()      ///初始化
{
    top = 0;
    dfs_clock = 1;
    for(int i = 0; i < N; i++)
    {
        head[i] = -1;
        dfn[i] = 0;
        low[i] = 0;
        degree[i] = 0;
    }
}

void add(int u,int v)   ///邻接表加边
{
    E[top].en = v;
    E[top].next = head[u];
    head[u] = top++;
}

void dfs(int u,int fa)
{
    dfn[u] = low[u] = dfs_clock++;
    for(int i = head[u]; i != -1; i = E[i].next)
    {
        int v = E[i].en;
        if(v == fa)
            continue;
        if(!dfn[v])
            dfs(v,u);
        low[u] = min(low[u],low[v]);   ///这样写看着好清爽
    }
}

int Tarjan()
{
    int cnt = 0;
    dfs(1,-1);
    for(int i = 1; i <= n; i++)    ///计算每个点的度
    {
        for(int j = head[i]; j != -1; j = E[j].next)
        {
            int v = E[j].en;
            if(low[i] != low[v])
                degree[low[i]]++;
        }
    }
    for(int i = 1; i <= n; i++)    ///度为1的就是叶子节点
        if(degree[i] == 1)
            cnt++;
    return (cnt+1)/2;
}

int main()
{
    while(scanf("%d%d",&n,&m) != EOF)
    {
        Init();
        for(int i = 1; i <= m; i++)
        {
            int u,v;
            scanf("%d%d",&u,&v);
            add(u,v);
            add(v,u);
        }
        int ans = Tarjan();
        printf("%d\n",ans);
    }
    return 0;
}


POJ 3352 Road Construction

标签:

原文地址:http://blog.csdn.net/ftqooo/article/details/51355894

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!