标签:
A Sweet Journey
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 741 Accepted Submission(s): 383
Problem Description
Master Di plans to take his girlfriend for a travel by bike. Their journey, which can be seen as a line segment of length L, is a road of swamps and flats. In the swamp, it takes A point strengths per meter for Master Di to ride; In the flats, Master Di will
regain B point strengths per meter when riding. Master Di wonders:In the beginning, he needs to prepare how much minimum strengths. (Except riding all the time,Master Di has no other choice)
Input
In the first line there is an integer t (1≤t≤50),
indicating the number of test cases.
For each test case:
The first line contains four integers, n, A, B, L.
Next n lines, each line contains two integers: Li,Ri,
which represents the interval [Li,Ri] is
swamp.
1≤n≤100,1≤L≤105,1≤A≤10,1≤B≤10,1≤Li<Ri≤L.
Make sure intervals are not overlapped which means Ri<Li+1 for
each i (1≤i<n).
Others are all flats except the swamps.
Output
For each text case:
Please output “Case #k: answer”(without quotes) one line, where k means the case number counting from 1, and the answer is his minimum strengths in the beginning.
Sample Input
Sample Output
Source
题意:在区间 [0, L] 中有沼泽和陆地,经过沼泽每米损失a体力,经过陆地每米回复b体力,要从0到L;求在0处所需的最小体力。
思路:只需要求经过一块沼泽需要的最大体力就行
#include <stdio.h>
#include <algorithm>
using namespace std;
int main ()
{
int T,n,a,b,L;
scanf("%d",&T);
for (int i=1; i<=T; i++)
{
scanf("%d%d%d%d",&n,&a,&b,&L);
int p=0,sum=0,minx=99999;//p用来标记上一个沼泽结束位置
int l,r;
while (n--)
{
scanf("%d%d",&l,&r);
sum = sum+b*(l-p)-a*(r-l);//每经过一片沼泽所剩于体力
minx = min(minx, sum);//途中所需的最大体力
p = r;//更新p
}
printf("Case #%d: ",i);
if (minx < 0)
printf("%d\n",-minx);
else
printf("0\n");
}
return 0;
}
HDU 5477 A Sweet Journey
标签:
原文地址:http://blog.csdn.net/yao1373446012/article/details/51355001