标签:
Rectangles
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 20183 Accepted Submission(s): 6537
Problem Description
Given two rectangles and the coordinates of two points on the diagonals of each rectangle,you have to calculate the area of the intersected part of two rectangles. its sides are parallel to OX and OY .
Input
Input The first line of input is 8 positive numbers which indicate the coordinates of four points that must be on each diagonal.The 8 numbers are x1,y1,x2,y2,x3,y3,x4,y4.That means the two points on the
first rectangle are(x1,y1),(x2,y2);the other two points on the second rectangle are (x3,y3),(x4,y4).
Output
Output For each case output the area of their intersected part in a single line.accurate up to 2 decimal places.
Sample Input
1.00 1.00 3.00 3.00 2.00 2.00 4.00 4.00
5.00 5.00 13.00 13.00 4.00 4.00 12.50 12.50
Sample Output
Author
seeyou
Source
题解:求出两个长方形相交的面积,如果重合的话就为0。
AC代码:
#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<cstdlib>
#include<iomanip>
#include<algorithm>
typedef long long LL;
using namespace std;
int main()
{
double x1,y1,x2,y2,x3,y3,x4,y4;
while(cin>>x1>>y1>>x2>>y2>>x3>>y3>>x4>>y4)
{
//保证左边是右下角,右边的数是左上角 (画个图吧...)
if(x1>x2)swap(x1,x2);
if(y1>y2)swap(y1,y2);
if(x3>x4)swap(x3,x4);
if(y3>y4)swap(y3,y4);
//画个图就知道是什么意思了
x1=max(x1,x3);
y1=max(y1,y3);
x2=min(x2,x4);
y2=min(y2,y4);
printf("%.2lf\n",x1>x2||y1>y2? 0:(x2-x1)*(y2-y1));//注意重合的情况
}
return 0;
}
HDU 2056 Rectangles(计算相交面积)
标签:
原文地址:http://blog.csdn.net/liangzhaoyang1/article/details/51344992