码迷,mamicode.com
首页 > 其他好文 > 详细

最短路水题 HDU 1874畅通工程续

时间:2016-05-13 00:53:13      阅读:170      评论:0      收藏:0      [点我收藏+]

标签:

Description

某省自从实行了很多年的畅通工程计划后,终于修建了很多路。不过路多了也不好,每次要从一个城镇到另一个城镇时,都有许多种道路方案可以选择,而某些方案要比另一些方案行走的距离要短很多。这让行人很困扰。 

现在,已知起点和终点,请你计算出要从起点到终点,最短需要行走多少距离。
 

Input

本题目包含多组数据,请处理到文件结束。 
每组数据第一行包含两个正整数N和M(0<N<200,0<M<1000),分别代表现有城镇的数目和已修建的道路的数目。城镇分别以0~N-1编号。 
接下来是M行道路信息。每一行有三个整数A,B,X(0<=A,B<N,A!=B,0<X<10000),表示城镇A和城镇B之间有一条长度为X的双向道路。 
再接下一行有两个整数S,T(0<=S,T<N),分别代表起点和终点。
 

Output

对于每组数据,请在一行里输出最短需要行走的距离。如果不存在从S到T的路线,就输出-1. 
 

Sample Input

3 3 0 1 1 0 2 3 1 2 1 0 2 3 1 0 1 1 1 2
 

Sample Output

2 -1
#include<stdio.h>
#include<string.h>
#define MAX 2000001
int dist[1005];
int c[205][205];
int n,m;
bool s[205];
int cnt = 0;
void Dijkstra(int v)
{
	int u;
	dist[v] = 0;
	for(int j = 0;j < n;j ++)
	{
		u = -1;
		int tmp = MAX;
		//找到dist中最小的值得下标 
		for(int i = 0;i < n;i ++)
			if(s[i]&&dist[i] < tmp)
			{
				tmp = dist[i];
				u=i;	
			}
		if(u == -1)
			break;
		s[u] = false;
		//更新dist 
		for(int i = 0;i < n;i ++)
		{
			int sum = c[u][i] + dist[u];
			if(s[i]&&dist[i] > sum)
			{
				dist[i] = sum;
			}
		}
	}
	
}
int main()
{
	//freopen("out.txt","r",stdin);
	//freopen("in.txt","w",stdout);
	while(~scanf("%d%d",&n,&m))
	{
		for(int i = 0;i < n;i ++)
			for(int j = 0;j < n;j ++)
				c[i][j] = MAX;
		for(int i = 0;i < n;i ++)
		{
			dist[i] = MAX;
			s[i] = true;
		}
			
		for(int i = 0;i < m;i ++)
		{
			int a,b,x;
			scanf("%d%d%d",&a,&b,&x);
			if(c[a][b]>x)
			{
				c[a][b]=x;
				c[b][a]=x;	
			}
		}
		int x,y;
		scanf("%d %d",&x,&y);
		Dijkstra(x);
		if(dist[y] >= MAX)
		dist[y] = -1;
		printf("%d\n",dist[y],cnt ++);
	}
	return 0;
}

最短路水题 HDU 1874畅通工程续

标签:

原文地址:http://blog.csdn.net/advanced_hwr/article/details/51347441

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!