码迷,mamicode.com
首页 > 其他好文 > 详细

poj 3278 bfs

时间:2016-05-13 01:51:27      阅读:152      评论:0      收藏:0      [点我收藏+]

标签:




链接:戳这里


Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K
Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input

5 17
Sample Output

4
Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.


题意:

x坐标轴上  人在位置n处  牛在位置k处, 人走到牛那里最少需要多少步

走的方式有三种:向左走、向右走、坐标位置*2


思路:bfs存下走到当前位置最少需要多少步 注意剪枝


代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<string>
#include<vector>
#include <ctime>
#include<queue>
#include<set>
#include<map>
#include<stack>
#include<iomanip>
#include<cmath>
#define mst(ss,b) memset((ss),(b),sizeof(ss))
#define maxn 0x3f3f3f3f
#define MAX 1000100
///#pragma comment(linker, "/STACK:102400000,102400000")
typedef long long ll;
typedef unsigned long long ull;
#define INF (1ll<<60)-1
using namespace std;
int vis[200100],n,k;
struct node{
    int x,step;
    node(int x=0,int step=0):x(x),step(step){}
};
void bfs(){
    mst(vis,0);
    queue<node> qu;
    qu.push(node(n,0));
    vis[n]=1;
    while(!qu.empty()){
        node now=qu.front();
        qu.pop();
        if(!vis[now.x+1] && now.x+1<100001){
            if(now.x+1==k) {
                cout<<now.step+1<<endl;
                return ;
            }
            vis[now.x+1]=1;
            qu.push(node(now.x+1,now.step+1));
        }
        if(!vis[now.x-1] && now.x-1>=0){
                if(now.x-1==k) {
                cout<<now.step+1<<endl;
                return ;
            }
            vis[now.x-1]=1;
            qu.push(node(now.x-1,now.step+1));
        }
        if(!vis[now.x*2] && now.x*2<100001){
            if(now.x*2==k) {
                cout<<now.step+1<<endl;
                return ;
            }
            vis[now.x*2]=1;
            qu.push(node(now.x*2,now.step+1));
        }
    }
}
int main(){
    while(scanf("%d%d",&n,&k)!=EOF){
        if(n==k) cout<<0<<endl;
        else bfs();
    }
    return 0;
}


poj 3278 bfs

标签:

原文地址:http://blog.csdn.net/libin66/article/details/51347388

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!