码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2318 叉积的应用+二分

时间:2016-05-13 03:07:08      阅读:166      评论:0      收藏:0      [点我收藏+]

标签:


Description

Calculate the number of toys that land in each bin of a partitioned toy box.
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys.

John‘s parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box.
技术分享
For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
 5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2


通过结果的正负判断两矢量之间的顺逆时针关系
若 a x b > 0表示a在b的顺时针方向上
若 a x b < 0表示a在b的逆时针方向上
若 a x b == 0表示a在b共线,但不确定方向是否相同

记玩具在点p0,某块板的上边点是p1,下边点是p2,p2p1(向量)×p2p0>0表示p0在p1p2的左面,<0表示在右面。接下来就是用二分法找出每个点所在的分区。

#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<vector>
#include<string>
#include<algorithm>
#define LL long long
#define inf 0x3f3f3f3f
using namespace std;
int n,m,xx,yy,x2,y2;
struct Line
{
    int u,l;
}line[5010];
int toy[5010];
bool isplace(int x,int y,int u,int l)
{
    if((x-l)*(yy-y2)-(y-y2)*(u-l)<0)
        return true;//左
    return false;
}
int binarysearch(int x,int y)
{
    int l=0,r=n;
    while(l<r)
    {
        int mid=(l+r)/2;
        if(isplace(x,y,line[mid].u,line[mid].l))
            r=mid;
        else
            l=mid+1;
    }
    return l;
}
int main()
{
    bool flag=0;
    while(cin>>n)
    {
        if(n==0)
            return 0;
        if(flag)
            cout<<endl;
        else
            flag=1;
        scanf("%d%d%d%d%d",&m,&xx,&yy,&x2,&y2);
        for(int i=0;i<=n-1;i++)
            scanf("%d%d",&line[i].u,&line[i].l);
        memset(toy,0,sizeof(toy));
        for(int i=0;i<=m-1;i++)
        {
            int a,b;
            scanf("%d%d",&a,&b);
            toy[binarysearch(a,b)]++;
        }
        for(int i=0;i<=n;i++)
            cout<<i<<": "<<toy[i]<<endl;
    }
    return 0;
}


poj 2318 叉积的应用+二分

标签:

原文地址:http://blog.csdn.net/winycg/article/details/51340837

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!