码迷,mamicode.com
首页 > 其他好文 > 详细

1001 of dp

时间:2016-05-13 04:39:36      阅读:117      评论:0      收藏:0      [点我收藏+]

标签:

Problem A

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 258   Accepted Submission(s) : 50
Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.<br>
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).<br>
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.<br>

Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
Case 1: 14 1 4 Case 2: 7 1 6
        题目要求:在一串数字中找到最加和最大的子序列。
        解题思路:若在第i的数字结束的最大子序列为d[i],则在第i+1个数字结束的最大子序列为d[i+1]=max[a[i+1],d[i+1]+a[i+1]]
    由状态转移方程可以得到的每位的最大子序列,再由另为两个数组保存到该数时所取的开头和结尾数列,输出最大的的d[i]和开始终点位置即可。
     
#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
    //freopen("right.txt","r",stdin);
    int i,t,n,b,e,s,x,max,before;
    cin>>t;
   for(int j=1;j<=t;j++)
    {
        cin>>n;
        for(i=1;i<=n;i++)
        {//cout<<b<<endl;
           cin>>s;
           if(i==1)
           {
               max=before=s;
               x=b=e=1;
           }
           else {
                if(before<0)
                {
                    before=s;x=i;
                }
                else before+=s;
                if(before>max)
                {max=before;b=x;e=i;}
           }
        }
        if(j!=1)cout<<endl;
           printf("Case %d:\n%d %d %d\n",j,max,b,e);
    }
}

1001 of dp

标签:

原文地址:http://blog.csdn.net/toy_block/article/details/51338119

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!