码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ 4901 The Romantic Hero

时间:2014-07-31 23:57:30      阅读:473      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   java   os   strong   io   


DP....扫两遍组合起来

The Romantic Hero

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 547    Accepted Submission(s): 217


Problem Description
There is an old country and the king fell in love with a devil. The devil always asks the king to do some crazy things. Although the king used to be wise and beloved by his people. Now he is just like a boy in love and can’t refuse any request from the devil. Also, this devil is looking like a very cute Loli.

You may wonder why this country has such an interesting tradition? It has a very long story, but I won‘t tell you :).

Let us continue, the party princess‘s knight win the algorithm contest. When the devil hears about that, she decided to take some action.

But before that, there is another party arose recently, the ‘MengMengDa‘ party, everyone in this party feel everything is ‘MengMengDa‘ and acts like a ‘MengMengDa‘ guy.

While they are very pleased about that, it brings many people in this kingdom troubles. So they decided to stop them.

Our hero z*p come again, actually he is very good at Algorithm contest, so he invites the leader of the ‘MengMengda‘ party xiaod*o to compete in an algorithm contest.

As z*p is both handsome and talkative, he has many girl friends to deal with, on the contest day, he find he has 3 dating to complete and have no time to compete, so he let you to solve the problems for him.

And the easiest problem in this contest is like that:

There is n number a_1,a_2,...,a_n on the line. You can choose two set S(a_s1,a_s2,..,a_sk) and T(a_t1,a_t2,...,a_tm). Each element in S should be at the left of every element in T.(si < tj for all i,j). S and T shouldn‘t be empty.

And what we want is the bitwise XOR of each element in S is equal to the bitwise AND of each element in T.

How many ways are there to choose such two sets? You should output the result modulo 10^9+7.
 

Input
The first line contains an integer T, denoting the number of the test cases.
For each test case, the first line contains a integers n.
The next line contains n integers a_1,a_2,...,a_n which are separated by a single space.

n<=10^3, 0 <= a_i <1024, T<=20.
 

Output
For each test case, output the result in one line.
 

Sample Input
2 3 1 2 3 4 1 2 3 3
 

Sample Output
1 4
 

Author
WJMZBMR
 

Source
 



#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

typedef long long int LL;

const LL mod=(1e9+7);

int n,a[1100];
LL dl[1100][2100],sdl[1100][2100];
LL dr[1100][2100],sdr[1100][2100];

void init()
{
    memset(dl,0,sizeof(dl));
    memset(sdl,0,sizeof(sdl));
    memset(dr,0,sizeof(dr));
    memset(sdr,0,sizeof(sdr));
}

int main()
{
    int T_T;
    scanf("%d",&T_T);
    while(T_T--)
    {
        scanf("%d",&n);
        init();
        for(int i=1;i<=n;i++)
            scanf("%d",a+i);
        dl[1][a[1]]=sdl[1][a[1]]=1LL;
        for(int i=2;i<=n;i++)
        {
            for(int j=0;j<2048;j++)
            {
                dl[i][a[i]^j]=(dl[i][a[i]^j]+sdl[i-1][j])%mod;
            }
            dl[i][a[i]]=(dl[i][a[i]]+1)%mod;
            for(int j=0;j<2048;j++)
                sdl[i][j]=(sdl[i-1][j]+dl[i][j])%mod;
        }
        dr[n][a[n]]=sdr[n][a[n]]=1LL;
        for(int i=n-1;i>=1;i--)
        {
            for(int j=0;j<2048;j++)
            {
                dr[i][j&a[i]]=(dr[i][j&a[i]]+sdr[i+1][j])%mod;
            }
            dr[i][a[i]]=(dr[i][a[i]]+1)%mod;
            for(int j=0;j<2048;j++)
                sdr[i][j]=(sdr[i+1][j]+dr[i][j])%mod;
        }
        LL ret=0;
        for(int i=1;i<n;i++)
        {
            for(int j=0;j<2048;j++)
            {
                if(sdl[i][j]&&dr[i+1][j])
                    ret=(ret+sdl[i][j]*dr[i+1][j]%mod)%mod;
            }
        }
        printf("%I64d\n",ret);
    }
    return 0;
}



HDOJ 4901 The Romantic Hero,布布扣,bubuko.com

HDOJ 4901 The Romantic Hero

标签:des   style   http   color   java   os   strong   io   

原文地址:http://blog.csdn.net/ck_boss/article/details/38326379

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!