码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 4901 The Romantic Hero(二维dp)

时间:2014-08-01 00:08:20      阅读:400      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   java   os   strong   io   

题目大意:给你n个数字,然后分成两份,前边的一份里面的元素进行异或,后面的一份里面的元素进行与。分的时候按照给的先后数序取数,后面的里面的所有的元素的下标一定比前面的大。问你有多上种放元素的方法可以使得前面异或的值和后面与的值相等。

dp[x][y] 表示走到第x步,得到y这个数字一共有多少种方法。

但是需要注意这里得分一下,不能直接用dp数组存种数,你需要分一下从上一层过来的次数,和这一层自己可以到达的次数。然后取和的时候前后两个集合的种数进行乘法,注意边乘边取余。

顺便给一组数据:

4

3 3 3 3

输出:12。

The Romantic Hero

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 459    Accepted Submission(s): 173


Problem Description
There is an old country and the king fell in love with a devil. The devil always asks the king to do some crazy things. Although the king used to be wise and beloved by his people. Now he is just like a boy in love and can’t refuse any request from the devil. Also, this devil is looking like a very cute Loli.

You may wonder why this country has such an interesting tradition? It has a very long story, but I won‘t tell you :).

Let us continue, the party princess‘s knight win the algorithm contest. When the devil hears about that, she decided to take some action.

But before that, there is another party arose recently, the ‘MengMengDa‘ party, everyone in this party feel everything is ‘MengMengDa‘ and acts like a ‘MengMengDa‘ guy.

While they are very pleased about that, it brings many people in this kingdom troubles. So they decided to stop them.

Our hero z*p come again, actually he is very good at Algorithm contest, so he invites the leader of the ‘MengMengda‘ party xiaod*o to compete in an algorithm contest.

As z*p is both handsome and talkative, he has many girl friends to deal with, on the contest day, he find he has 3 dating to complete and have no time to compete, so he let you to solve the problems for him.

And the easiest problem in this contest is like that:

There is n number a_1,a_2,...,a_n on the line. You can choose two set S(a_s1,a_s2,..,a_sk) and T(a_t1,a_t2,...,a_tm). Each element in S should be at the left of every element in T.(si < tj for all i,j). S and T shouldn‘t be empty.

And what we want is the bitwise XOR of each element in S is equal to the bitwise AND of each element in T.

How many ways are there to choose such two sets? You should output the result modulo 10^9+7.
 

Input
The first line contains an integer T, denoting the number of the test cases.
For each test case, the first line contains a integers n.
The next line contains n integers a_1,a_2,...,a_n which are separated by a single space.

n<=10^3, 0 <= a_i <1024, T<=20.
 

Output
For each test case, output the result in one line.
 

Sample Input
2 3 1 2 3 4 1 2 3 3
 

Sample Output
1 4
 

Author
WJMZBMR
 

Source
 
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
#define max( x, y )  ( ((x) > (y)) ? (x) : (y) )
#define min( x, y )  ( ((x) < (y)) ? (x) : (y) )
#define Mod 1000000007
#define LL long long

using namespace std;

const int maxn = 1200;
LL dp1[maxn][maxn];
LL dp2[maxn][maxn];
LL dp11[maxn][maxn];
LL dp22[maxn][maxn];

int num[maxn];

int main()
{
    int T;
    cin >>T;
    while(T--)
    {
        int n;
        scanf("%d",&n);
        for(int i = 1; i <= n; i++) scanf("%d", &num[i]);
        for(int i = 1; i <= n; i++)
            for(int j = 0; j < 1024; j++) dp1[i][j] = dp2[i][j] = 0;
        for(int i = 0; i < 1024; i++) dp11[1][i] = dp22[n][i] = 0;
        dp1[1][num[1]] ++;
        dp11[1][num[1]] ++;
        for(int i = 2; i <= n; i++)
        {
            dp1[i][num[i]]++;
            for(int j = 0; j < 1024; j++)
            {
                if(dp11[i-1][j])
                {
                    dp1[i][j^num[i]] += dp11[i-1][j];
                    dp1[i][j^num[i]] %= Mod;
                }
            }

            for(int j = 0; j < 1024; j++)
            {
                dp11[i][j] = dp1[i][j]+dp11[i-1][j];
                dp11[i][j] %= Mod;
            }
        }
        dp2[n][num[n]]++;
        dp22[n][num[n]]++;
        for(int i = n-1; i >= 1; i--)
        {
            dp2[i][num[i]] ++;
            for(int j = 0; j < 1024; j++)
            {
                if(dp22[i+1][j])
                {
                    dp2[i][j&num[i]] += dp22[i+1][j];
                    dp2[i][j&num[i]] %= Mod;
                }
            }

            for(int j = 0; j < 1024; j++)
            {
                dp22[i][j] = dp2[i][j]+dp22[i+1][j];
                dp22[i][j] %= Mod;
            }
        }
        for(int i = n-1; i >= 1; i--)
        {
            for(int j = 0; j < 1024; j++)
            {
                dp2[i][j] += dp2[i+1][j];
                dp2[i][j] %= Mod;
            }
        }
        LL sum = 0;
        for(int i = 1; i <= n; i++)
        {
            for(int j = 0; j < 1024; j++)
            {
                if(dp1[i][j] && dp2[i+1][j])
                {
                    sum += ((dp1[i][j]%Mod)*(dp2[i+1][j]%Mod))%Mod;
                }
            }
        }
        cout<<(sum%Mod)<<endl;
    }
    return 0;
}


HDU 4901 The Romantic Hero(二维dp),布布扣,bubuko.com

HDU 4901 The Romantic Hero(二维dp)

标签:des   style   http   color   java   os   strong   io   

原文地址:http://blog.csdn.net/xu12110501127/article/details/38323525

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!