码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3628 Bookshelf 2 (01背包)

时间:2014-08-01 00:09:50      阅读:249      评论:0      收藏:0      [点我收藏+]

标签:poj   动态规划   动规   dp   背包   

Bookshelf 2
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 7496   Accepted: 3451

Description

Farmer John recently bought another bookshelf for the cow library, but the shelf is getting filled up quite quickly, and now the only available space is at the top.

FJ has N cows (1 ≤ N ≤ 20) each with some height of Hi (1 ≤ Hi ≤ 1,000,000 - these are very tall cows). The bookshelf has a height of B (1 ≤ BS, where S is the sum of the heights of all cows).

To reach the top of the bookshelf, one or more of the cows can stand on top of each other in a stack, so that their total height is the sum of each of their individual heights. This total height must be no less than the height of the bookshelf in order for the cows to reach the top.

Since a taller stack of cows than necessary can be dangerous, your job is to find the set of cows that produces a stack of the smallest height possible such that the stack can reach the bookshelf. Your program should print the minimal ‘excess‘ height between the optimal stack of cows and the bookshelf.

Input

* Line 1: Two space-separated integers: N and B
* Lines 2..N+1: Line i+1 contains a single integer: Hi

Output

* Line 1: A single integer representing the (non-negative) difference between the total height of the optimal set of cows and the height of the shelf.

Sample Input

5 16
3
1
3
5
6

Sample Output

1

Source

USACO 2007 December Bronze

题意:就是给出n和b,然后给出n个数,用这n个数中的某些,求出一个和,这个和是>=b的最小值,输出最小值与b的差。

分析:这道题很简单,是很明显的01背包问题,这里的n个物品,每个物品的重量为c[i],价值为w[i]并且c[i]==w[i],,容量为所有c[i]的和sum。只要在f[]中从头开始找,找到一个最小>=b的就是题目要的解

一开始看错题了,以为是最接近b的值,WA无数次。
代码:46MS
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
using namespace std;
#define M 1000005
#define N 10005
int map[N],dp[M];
int main()
{
    int i,j,n,v,sum;
    while(cin>>n>>v)
    {
      memset(dp,0,sizeof(dp));
      memset(map,0,sizeof(map));
      sum=0;
      for(i=1;i<=n;i++) {cin>>map[i];sum+=map[i];}
      for(i=1;i<=n;i++)
      for(j=sum;j>=map[i];j--)
      dp[j]=max(dp[j],dp[j-map[i]]+map[i]);
      for(i=1;i<=sum;i++)
      {
          if(dp[i]>=v)    //明显,第一个比v大的一定满足条件。
          {cout<<dp[i]-v<<endl;break;}
      }
    }
    return 0;
}


POJ 3628 Bookshelf 2 (01背包),布布扣,bubuko.com

POJ 3628 Bookshelf 2 (01背包)

标签:poj   动态规划   动规   dp   背包   

原文地址:http://blog.csdn.net/qq2256420822/article/details/38323471

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!