码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1696 Space Ant (极角排序)

时间:2014-08-01 10:39:13      阅读:247      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   os   strong   io   

链接:http://poj.org/problem?id=1696
Space Ant
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 3077   Accepted: 1965

Description

The most exciting space discovery occurred at the end of the 20th century. In 1999, scientists traced down an ant-like creature in the planet Y1999 and called it M11. It has only one eye on the left side of its head and just three feet all on the right side of its body and suffers from three walking limitations: 
  1. It can not turn right due to its special body structure. 
  2. It leaves a red path while walking. 
  3. It hates to pass over a previously red colored path, and never does that.

The pictures transmitted by the Discovery space ship depicts that plants in the Y1999 grow in special points on the planet. Analysis of several thousands of the pictures have resulted in discovering a magic coordinate system governing the grow points of the plants. In this coordinate system with x and y axes, no two plants share the same x or y
An M11 needs to eat exactly one plant in each day to stay alive. When it eats one plant, it remains there for the rest of the day with no move. Next day, it looks for another plant to go there and eat it. If it can not reach any other plant it dies by the end of the day. Notice that it can reach a plant in any distance. 
The problem is to find a path for an M11 to let it live longest. 
Input is a set of (x, y) coordinates of plants. Suppose A with the coordinates (xA, yA) is the plant with the least y-coordinate. M11 starts from point (0,yA) heading towards plant A. Notice that the solution path should not cross itself and all of the turns should be counter-clockwise. Also note that the solution may visit more than two plants located on a same straight line. 
bubuko.com,布布扣

Input

The first line of the input is M, the number of test cases to be solved (1 <= M <= 10). For each test case, the first line is N, the number of plants in that test case (1 <= N <= 50), followed by N lines for each plant data. Each plant data consists of three integers: the first number is the unique plant index (1..N), followed by two positive integers x and y representing the coordinates of the plant. Plants are sorted by the increasing order on their indices in the input file. Suppose that the values of coordinates are at most 100.

Output

Output should have one separate line for the solution of each test case. A solution is the number of plants on the solution path, followed by the indices of visiting plants in the path in the order of their visits.

Sample Input

2
10
1 4 5
2 9 8
3 5 9
4 1 7
5 3 2
6 6 3
7 10 10
8 8 1
9 2 4
10 7 6
14
1 6 11
2 11 9
3 8 7
4 12 8
5 9 20
6 3 2
7 1 6
8 2 13
9 15 1
10 14 17
11 13 19
12 5 18
13 7 3
14 10 16

Sample Output

10 8 7 3 4 9 5 6 2 1 10
14 9 10 11 5 12 8 7 6 13 4 14 1 3 2

Source

=======================================================================

好题,一开始没看懂测试样例,谁知道第一个是走过的路的数目,只要按极角排序后,所有点无疑都会走过一遍

然后就一直更新极角最小的那个,输出,并再次赋值

 

bubuko.com,布布扣
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#include <math.h>

using namespace std;
typedef struct
{
    int x,y,num;
}point;

point tmp;
int crossProduct(point a,point b,point c)
{
    return (c.x-a.x)*(b.y-a.y)-(c.y-a.y)*(b.x-a.x);
}

bool cmp1(point a,point b)
{
    return a.y<b.y;
}

int dist(point a,point b)
{
    return sqrt((double)(a.x-b.x)*(a.x-b.x)+(double)(a.y-b.y)*(a.y-b.y));
}

bool cmp2(point a,point b)
{
    int len=crossProduct(tmp,a,b);
    if(len == 0)
    {
        return dist(tmp,a)<dist(tmp,b);
    }
    return len<0;
}

point stk[105];

int main()
{
    int n,m,i,j,k,t;
    scanf("%d",&n);
    while(n--)
    {
        scanf("%d",&m);
        for(i=0;i<m;i++)
        {
            scanf("%d%d%d",&stk[i].num,&stk[i].x,&stk[i].y);
        }
        sort(stk,stk+m,cmp1);
        printf("%d %d ",m,stk[0].num);
        tmp=stk[0];
        for(i=1;i<m;i++)
        {
            sort(stk+i,stk+m,cmp2);
            printf("%d ",stk[i].num);
            tmp=stk[i];
        }
        printf("\n");
    }
    return 0;
}
View Code

 

poj 1696 Space Ant (极角排序),布布扣,bubuko.com

poj 1696 Space Ant (极角排序)

标签:des   style   blog   http   color   os   strong   io   

原文地址:http://www.cnblogs.com/ccccnzb/p/3884179.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!