码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1013 Digital Roots

时间:2014-08-01 10:52:11      阅读:280      评论:0      收藏:0      [点我收藏+]

标签:des   style   color   java   os   strong   io   for   

Digital Roots

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 48348    Accepted Submission(s): 15029


Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
 

Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
 

Output
For each integer in the input, output its digital root on a separate line of the output.
 

Sample Input
24 39 0
 

Sample Output
6 3
 

题意:给你一个数,求每个数位上的数字之和。如果和大于9,就继续求‘和’的每一个数位上的数字之和。

#include<stdio.h>	
#include<string.h>

int find(int sum)
{
	int ans=0;
        while(sum)
	{
		ans+=sum%10;
		sum=sum/10;
	}
	return ans;
}

int main ()
{
	int sum,ans;
	int i,j;
	char a[100005];
	while(~scanf("%s",a)&&a[0]!='0')
	{
		sum=0;
		for(i=0;i<strlen(a);i++)
			sum+=(a[i]-'0');
		
		while(sum>9) 
			sum=find(sum);  //递归
		
		printf("%d\n",sum);
	}
	return 0;
}




hdu 1013 Digital Roots,布布扣,bubuko.com

hdu 1013 Digital Roots

标签:des   style   color   java   os   strong   io   for   

原文地址:http://blog.csdn.net/fyxz1314/article/details/38332361

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!