码迷,mamicode.com
首页 > 其他好文 > 详细

HDU - 2795 Billboard

时间:2014-08-01 10:54:34      阅读:209      评论:0      收藏:0      [点我收藏+]

标签:des   style   os   io   for   art   ar   div   

Description

At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that‘s why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

Input

There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

Output

For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can‘t be put on the billboard, output "-1" for this announcement.
 

Sample Input

3 5 5 2 4 3 3 3
 

Sample Output

1 2 1 3 -1

题意:给你个h*w的黑板,然后再给你n张不同的1*w的海报,然后贴的 方式是优先贴最上面,然后是最左边的,问最后每张海报在第几层,不能贴的输出-1

思路:如果我们以宽或高作为区间的话,太大了,但是我们发现我们的n是最大的,就是说我们最多有n层,那么我们就以这个作为区间,然后每个线段的意思是:[l, r]层宽最大剩多少,剩下的是不难的单点更新

#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
#define lson(x) ((x) << 1)
#define rson(x) ((x) << 1 | 1)
using namespace std;
const int maxn = 200000;

int n, w, h;
struct seg {
	int w;
};

struct segment_tree {
	seg node[maxn<<2];

	void update(int pos) {
		node[pos].w = max(node[lson(pos)].w, node[rson(pos)].w);
	}

	void build(int l, int r, int pos) {
		if (l == r) {
			node[pos].w = w;
			return;
		}
		int m = l + r >> 1;
		build(l, m, lson(pos));
		build(m+1, r, rson(pos));
		update(pos);
	}

	void modify(int l, int r, int pos, int x) {
		if (x > node[pos].w) {
			printf("-1\n");
			return;
		}
		if (l == r) {
			printf("%d\n", l);
			node[pos].w -= x;
			return;
		}
		int m = l + r >> 1;
		if (x <= node[lson(pos)].w)
			modify(l, m, lson(pos), x);
		else if (x <= node[rson(pos)].w)
			modify(m+1, r, rson(pos), x);
		update(pos);
	}
} tree;

int main() {
	int a;
	while (scanf("%d%d%d", &h, &w, &n) != EOF) {
		if (h > n)
			h = n;
		tree.build(1, h, 1);
		for (int i = 1; i <= n; i++) {
			scanf("%d", &a);
			tree.modify(1, h, 1, a);
		}
	}
	return 0;
}



HDU - 2795 Billboard,布布扣,bubuko.com

HDU - 2795 Billboard

标签:des   style   os   io   for   art   ar   div   

原文地址:http://blog.csdn.net/u011345136/article/details/38331797

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!