码迷,mamicode.com
首页 > 其他好文 > 详细

Problem B(子序列问题)

时间:2016-05-17 13:16:56      阅读:158      评论:0      收藏:0      [点我收藏+]

标签:

Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = &lt;x1, x2, ..., xm&gt; another sequence Z = &lt;z1, z2, ..., zk&gt; is a subsequence of X if there exists a strictly increasing sequence &lt;i1, i2, ..., ik&gt; of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = &lt;a, b, f, c&gt; is a subsequence of X = &lt;a, b, c, f, b, c&gt; with index sequence &lt;1, 2, 4, 6&gt;. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. <br>The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. <br>

 

Sample Input
abcfbc abfcab
programming contest
abcd mnp
 
Sample Output
4
2
0
 
 
题意:给出两组字符串,找出两个字符串中最大个数相同的字符。
思路:设有字符串a[0...n],b[0...m],字符串a对应的是二维数组num的行,字符串b对应的是二维数组num的列。然后每次记录比较后的状态
 
代码:
 

#include <iostream>
#include <cstring>
using namespace std;

char str1[1005];
char str2[1005];
int dp[1005][1005];

int main()
{
  int i,j;
  int len1,len2;
  while(cin>>str1>>str2)
  {
    len1=strlen(str1);
    len2=strlen(str2);
    for(i=0;i<len1;i++)
    {
      dp[i][0]=0;
    }
    for(i=0;i<len2;i++)
    {
      dp[0][i]=0;
    }
    for(i=1;i<=len1;i++)
    {
      for(j=1;j<=len2;j++)
      {
        if(str1[i-1]==str2[j-1])
        {
          dp[i][j]=dp[i-1][j-1]+1;
        }
        else
        {
          dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
        }
      }
    }
    cout<<dp[len1][len2]<<endl;
  }
  return 0;
}

 
本题有多种方法可以做

 

Problem B(子序列问题)

标签:

原文地址:http://www.cnblogs.com/2016zhanggang/p/5501024.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!