码迷,mamicode.com
首页 > 其他好文 > 详细

ACM题目————STL练习之字符串替换

时间:2016-05-18 21:48:37      阅读:144      评论:0      收藏:0      [点我收藏+]

标签:

描述

编写一个程序实现将字符串中的所有"you"替换成"we"

输入
输入包含多行数据 

每行数据是一个字符串,长度不超过1000 
数据以EOF结束
输出
对于输入的每一行,输出替换后的字符串
样例输入
you are what you do
样例输出
    we are what we do
STL string 练手题:
熟悉 find 函数,以及 replace 函数
//Asimple
#include <iostream>
#include <string>

using namespace std;
string str, s1="you", s2="we";

int main()
{
    int pos;
    while( getline(cin,str) )
    {
        pos = str.find(s1,0);
        while( pos != string::npos )
        {
            str.replace(pos,3,s2);
            pos = str.find(s1,pos+1);
        }
        cout << str << endl ;
    }
    return 0;
}

 

ACM题目————STL练习之字符串替换

标签:

原文地址:http://www.cnblogs.com/Asimple/p/5506507.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!