码迷,mamicode.com
首页 > 其他好文 > 详细

tarjan+缩点

时间:2014-08-01 13:38:31      阅读:222      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   os   strong   io   for   

B - Popular Cows
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Every cow‘s dream is to become the most popular cow in the herd. In a herd of N (1 <= N <= 10,000) cows, you are given up to M (1 <= M <= 50,000) ordered pairs of the form (A, B) that tell you that cow A thinks that cow B is popular. Since popularity is transitive, if A thinks B is popular and B thinks C is popular, then A will also think that C is 
popular, even if this is not explicitly specified by an ordered pair in the input. Your task is to compute the number of cows that are considered popular by every other cow. 

Input

* Line 1: Two space-separated integers, N and M 

* Lines 2..1+M: Two space-separated numbers A and B, meaning that A thinks B is popular. 

Output

* Line 1: A single integer that is the number of cows who are considered popular by every other cow. 

Sample Input

3 3
1 2
2 1
2 3

Sample Output

1

在对图进行建立时,如果用矩阵会导致内存超限,用VEC会使后来的缩点变得麻烦,所以用邻接表是最佳选择:

#include<stdio.h>
#include<stack>;
#include<string.h>
using namespace std;
stack<int>S;
int dfn[10005],map[10005][110],low[10005],instack[10005],belong[10005],out[10005];
int index,bnt;
void tarjan(int i){
	dfn[i] = low[i] = ++index;
	S.push(i);
	instack[i] = 1;
	for(int j=1;j<=map[i][0];j++){
		int k = map[i][j];
		if(!dfn[k]){
			tarjan(k);
			low[i] = min(low[i],low[k]);
		}
		else if(instack[k]){
			low[i] = min(low[i],dfn[k]);
		}
		
	}
	if(low[i]  == dfn[i]){
		bnt ++;
		int k;
		do{
		    k = S.top();
			S.pop();
			instack[k] = 0;
			belong[k] = bnt;
		}while(i!=k);
	}
}
int main(){
	int m,n,sum;
	while(~scanf("%d%d",&n,&m)){
		int a,b,j;
	   index = bnt = sum = 0;
		memset(map,0,sizeof(map));
		memset(instack,0,sizeof(instack));
		memset(out,0,sizeof(out));
		memset(dfn,0,sizeof(dfn));
		for(int i=0;i<m;i++){
			scanf("%d%d",&a,&b);
			map[a][++map[a][0]] = b;
		}
		for(int i=1;i<=n;i++)
		if(!dfn[i]){
			tarjan(i);
		}
		for(int i=1;i<=n;i++){
			for(j = 1;j<=map[i][0];j++)
			if(belong[i]!=belong[map[i][j]])
			out[belong[i]]++;
		}
		int z=0;
		for(int i=1;i<=bnt;i++){
			if(out[i]==0){
				z++;
				for(int j=1;j<=n;j++)
				if(belong[j]==i)sum++;
			}
		}
		if(z==1)
		printf("%d\n",sum);
		else printf("0\n");
	
	}
}


tarjan+缩点,布布扣,bubuko.com

tarjan+缩点

标签:des   style   http   color   os   strong   io   for   

原文地址:http://blog.csdn.net/yuanhanchun/article/details/38334657

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!