码迷,mamicode.com
首页 > 其他好文 > 详细

1015

时间:2016-05-19 10:35:23      阅读:157      评论:0      收藏:0      [点我收藏+]

标签:

题目大意:

Problem Description
Give you a number on base ten,you should output it on base two.(0 < n < 1000)
 

 

Input
For each case there is a postive number n on base ten, end of file.
 

 

Output
For each case output a number on base two.
 

 

Sample Input
1 2 3
 

 

Sample Output
1 10 11
十进制转二进制
解题思路:
按照定义,对二求余
代码:
#include <iostream>
using namespace std;
int main()
{
    int a,i;
    int b[100];
    while(cin>>a)
    {
        i=0;
        while(a!=0)
        {
            b[i]=a%2;
            a/=2;
            i++;
        }
        for(i--;i>=0;i--)
            cout<<b[i];
        cout<<endl;
    }
    return 0;
}

 

1015

标签:

原文地址:http://www.cnblogs.com/Sikaozhe/p/5504581.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!