标签:des style http color os strong io for
Channel Allocation
Time Limit: 1000MS |
|
Memory Limit: 10000K |
Total Submissions: 12096 |
|
Accepted: 6191 |
Description
When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a strong signal. However, the channels used by each repeater must be carefully chosen so that nearby repeaters do not interfere
with one another. This condition is satisfied if adjacent repeaters use different channels.
Since the radio frequency spectrum is a precious resource, the number of channels required by a given network of repeaters should be minimised. You have to write a program that reads in a description of a repeater network and determines the minimum number of
channels required.
Input
The input consists of a number of maps of repeater networks. Each map begins with a line containing the number of repeaters. This is between 1 and 26, and the repeaters are referred to by consecutive upper-case letters of the alphabet starting with A. For example,
ten repeaters would have the names A,B,C,...,I and J. A network with zero repeaters indicates the end of input.
Following the number of repeaters is a list of adjacency relationships. Each line has the form:
A:BCDH
which indicates that the repeaters B, C, D and H are adjacent to the repeater A. The first line describes those adjacent to repeater A, the second those adjacent to B, and so on for all of the repeaters. If a repeater is not adjacent to any other, its line
has the form
A:
The repeaters are listed in alphabetical order.
Note that the adjacency is a symmetric relationship; if A is adjacent to B, then B is necessarily adjacent to A. Also, since the repeaters lie in a plane, the graph formed by connecting adjacent repeaters does not have any line segments that cross.
Output
For each map (except the final one with no repeaters), print a line containing the minumum number of channels needed so that no adjacent channels interfere. The sample output shows the format of this line. Take care that channels is in the singular form when
only one channel is required.
Sample Input
2
A:
B:
4
A:BC
B:ACD
C:ABD
D:BC
4
A:BCD
B:ACD
C:ABD
D:ABC
0
Sample Output
1 channel needed.
3 channels needed.
4 channels needed.
Source
Southern African 2001
具体参考:http://baike.baidu.com/view/4061222.htm?fr=aladdin
AC代码:
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
int G[30][30];
int f[30];
int a[30];
int n,ans;
int judge(int k){
for(int i=1;i<k;i++)
if(G[k][i] && f[k]==f[i])
return 0;
return 1;
}
int main(){
while(cin>>n&&n){
memset(f,0,sizeof(f));
memset(G,0,sizeof(G));
for(int i=1;i<=n;i++){
char ch[30];
cin>>ch;
for(int j=2;j<strlen(ch);j++){
G[i][ch[j]-'A'+1]=1;
}
}
ans=99;
int k=1;
while(k>=1){
f[k]++;
while(f[k]<=4)
if(judge(k))
break;
else
f[k]++;
if(f[k]<=4 && k==4){ //成功
int mx=0;
memset(a,0,sizeof(a));
for(int i=1;i<=n;i++){ //找出用了几种颜色
if(a[f[i]]==0){
a[f[i]]++;
mx++;
}
}
if(ans>mx)
ans=mx;
}
else if(f[k]<=4 && k<4){ //访问下一节点
k++;
}
else{
f[k]=0;
k--; //回溯
}
}
if(ans==1)
cout<<ans<<' '<<"channel needed."<<endl;
else
cout<<ans<<' '<<"channels needed."<<endl;
}
return 0;
}
poj 1129(图的着色问题),布布扣,bubuko.com
poj 1129(图的着色问题)
标签:des style http color os strong io for
原文地址:http://blog.csdn.net/my_acm/article/details/38332837