码迷,mamicode.com
首页 > 其他好文 > 详细

HDU2124 Repair the Wall(贪心)

时间:2016-05-19 23:20:36      阅读:174      评论:0      收藏:0      [点我收藏+]

标签:

Problem Description

Long time ago , Kitty lived in a small village. The air was fresh and the scenery was very beautiful. The only thing that troubled her is the typhoon.

When the typhoon came, everything is terrible. It kept blowing and raining for a long time. And what made the situation worse was that all of Kitty‘s walls were made of wood.

One day, Kitty found that there was a crack in the wall. The shape of the crack is
a rectangle with the size of 1×L (in inch). Luckly Kitty got N blocks and a saw(锯子) from her neighbors.
The shape of the blocks were rectangle too, and the width of all blocks were 1 inch. So, with the help of saw, Kitty could cut down some of the blocks(of course she could use it directly without cutting) and put them in the crack, and the wall may be repaired perfectly, without any gap.

Now, Kitty knew the size of each blocks, and wanted to use as fewer as possible of the blocks to repair the wall, could you help her ?

Input

The problem contains many test cases, please process to the end of file( EOF ).
Each test case contains two lines.
In the first line, there are two integers L(0<L<1000000000) and N(0<=N<600) which
mentioned above.
In the second line, there are N positive integers. The ith integer Ai(0<Ai<1000000000 ) means that the ith block has the size of 1×Ai (in inch).

Output

For each test case , print an integer which represents the minimal number of blocks are needed.
If Kitty could not repair the wall, just print "impossible" instead.

Sample Input

5 3
3 2 1
5 2
2 1

Sample Output

2
impossible

Author

linle

Source

HDU 2007-10 Programming Contest 
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
const int maxn=600+10;
bool cmp(int a,int b)
{
    return a>b;
}
int main()
{
    int len,n,i,res;
    int a[maxn];
    while(scanf("%d%d",&len,&n)!=EOF)
    {
        for(i=0;i<n;i++)scanf("%d",&a[i]);
        sort(a,a+n,cmp);
        res=0;
        for(i=0;i<n;i++)
        {
           if(a[i]>=len)
           {
               res++;
               len-=a[i];
               break;
           }
           else
           {
               len-=a[i];
               res++;
           } 
           }
           if(len>0)printf("impossible\n");
           else printf("%d\n",res);
    }
    return 0;
}

 

HDU2124 Repair the Wall(贪心)

标签:

原文地址:http://www.cnblogs.com/Annetree/p/5510393.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!