码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2140 Herd Sums

时间:2016-05-19 23:24:30      阅读:237      评论:0      收藏:0      [点我收藏+]

标签:

http://poj.org/problem?id=2140

Description

The cows in farmer John‘s herd are numbered and branded with consecutive integers from 1 to N (1 <= N <= 10,000,000).  When the cows come to the barn for milking, they always come in sequential order from 1 to N.
Farmer John, who majored in mathematics in college and loves numbers, often looks for patterns.  He has noticed that when he has exactly 15 cows in his herd, there are precisely four ways that the numbers on any set of one or more consecutive cows can add up to 15 (the same as the total number of cows).  They are: 15, 7+8, 4+5+6, and 1+2+3+4+5.
When the number of cows in the herd is 10, the number of ways he can sum consecutive cows and get 10 drops to 2: namely 1+2+3+4 and 10.
Write a program that will compute the number of ways farmer John can sum the numbers on consecutive cows to equal N.  Do not use precomputation to solve this problem.

Input

* Line 1: A single integer: N

Output

* Line 1: A single integer that is the number of ways consecutive cow brands can sum to N.

Sample Input

15

Sample Output

  4

ps:consecutive  连续地

 

 

水题.....一次过

//{头文件
#include <algorithm>
#include <bitset>
#include <cassert>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <functional>
#include <iomanip>
#include <iostream>
#include <list>
#include <map>
#include <queue>
#include <set>
#include <sstream>
#include <stack>
#include <string>
#include <vector>
using namespace std;
//}头文件

double N;

bool f(int n)        //n为几个数组相连
{
    double n0 = n,k = N / n0;
    int t = k;
    if( n%2 ){
        if(t == k){
            if(t - n/2 > 0)return true;
        }
    }
    else {
        if( t * n + n/2 == N){
            if(t + 1 - n/2 >0)return true;
        }
    }
    return false;
}

int main() 
{
    cin >> N;
    int T = 1;
    for(int i = 2; i < N/2;i++){
        if(f(i))T++;
    }
    cout << T <<endl;
    //system("pause");
    return 0;
}

 

POJ 2140 Herd Sums

标签:

原文地址:http://www.cnblogs.com/farewell-farewell/p/5500536.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!