码迷,mamicode.com
首页 > 其他好文 > 详细

Charm Bracelet(01背包)

时间:2014-08-01 16:12:31      阅读:248      评论:0      收藏:0      [点我收藏+]

标签:背包问题   dp   

Problem Description

Bessie has gone to the mall‘s jewelry store and spies a charm bracelet. Of course, she‘d like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a ‘desirability‘ factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

 

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

 

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

 

Sample Input
4 6 1 4 2 6 3 12 2 7
 

Sample Output
23
 


#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
int dp[40000], w[40000], v[40000];
int n, t, m;
int main()
{
    while (cin >> n >> m) {
        memset(dp,0,sizeof(dp));
        for (int i = 1; i <=n; i++) {
            cin >> v[i] >> w[i];
        }
        for (int i = 1; i <=n; i++)
            for (int j = m; j >= v[i]; j--)
                dp[j] = max(dp[j], dp[j - v[i]] + w[i]);
            cout<<dp[m]<<endl;
    }
    return 0;
}


Charm Bracelet(01背包),布布扣,bubuko.com

Charm Bracelet(01背包)

标签:背包问题   dp   

原文地址:http://blog.csdn.net/zhangweiacm/article/details/38336297

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!