码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 2841 Visible Trees 容斥原理

时间:2016-05-21 21:52:30      阅读:233      评论:0      收藏:0      [点我收藏+]

标签:

Visible Trees

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)


Problem Description
There are many trees forming a m * n grid, the grid starts from (1,1). Farmer Sherlock is standing at (0,0) point. He wonders how many trees he can see.

If two trees and Sherlock are in one line, Farmer Sherlock can only see the tree nearest to him.
 

 

Input
The first line contains one integer t, represents the number of test cases. Then there are multiple test cases. For each test case there is one line containing two integers m and n(1 ≤ m, n ≤ 100000)
 

 

Output
For each test case output one line represents the number of trees Farmer Sherlock can see.
 

 

Sample Input
2 1 1 2 3
 

 

Sample Output
1 5
 

 

Source
题意:一个人站在(0,0)的位置,如果到两个点那个人的位置的斜率相等则无法看到远处的那个点;
思路:找出(1-m)与i互质的个数 1<=i<=n;复杂度o(nsqrt(n));
#include<bits/stdc++.h>
using namespace std;
#define ll __int64
#define inf 1e18
ll p[100],flag,x,ans;
ll getp(ll x)
{
    flag=0;
    for(ll i=2;i*i<=x;i++)
    {
        if(x%i==0)
        {
            p[flag++]=i;
            while(x%i==0)
            x/=i;
        }
    }
    if(x!=1)
    p[flag++]=x;
}
ll gcd(ll x,ll y)
{
    return y==0?x:gcd(y,x%y);
}
void dfs(ll lcm,ll step,ll pos)
{
    if(lcm>x)return;
    if(pos==flag)
    {
        if(step&1)
        ans+=x/lcm;
        else
        ans-=x/lcm;
        return;
    }
    dfs(lcm,step,pos+1);
    dfs(lcm/gcd(lcm,p[pos])*p[pos],step+1,pos+1);
}
int main()
{
    ll y,z,i,t;
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%I64d%I64d",&x,&y);
        ans=0;
        for(i=1;i<=y;i++)
        {
            getp(i);
            dfs(1,1,0);
        }
        printf("%I64d\n",ans);
    }
    return 0;
}

 

 
 

hdu 2841 Visible Trees 容斥原理

标签:

原文地址:http://www.cnblogs.com/jhz033/p/5515482.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!