码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1010 Tempter of the Bone

时间:2016-05-21 23:19:15      阅读:199      评论:0      收藏:0      [点我收藏+]

标签:

 

Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
 

 

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

‘X‘: a block of wall, which the doggie cannot enter; 
‘S‘: the start point of the doggie; 
‘D‘: the Door; or
‘.‘: an empty block.

The input is terminated with three 0‘s. This test case is not to be processed.
 

 

Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
 

 

Sample Input
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
 

 

Sample Output
NO YES
 
//第一道搜索题,学习了奇偶性剪枝,奇数-奇数=偶数 偶数-偶数=偶数 但是奇数-偶数=奇数
 
#include<iostream>
#include<cmath>
#include<cstring>
using namespace std;
int n,m,t;
char data[10][10];
int ki,kj,zi,zj,wall,flag;
int to[4][2]={{0,1},{0,-1},{1,0},{-1,0}};

void dfs(int i,int j,int cnt)
{
    if(i<1||j<1||i>n||j>m) return ;
    if(cnt==t&&i==zi&&j==zj)
    flag=1;
    if(flag==1)
    return ;
    int s1=i-zi;
    int s2=j-zj;
    if(s1<0)
    s1=-s1;
    if(s2<0)
    s2=-s2;
    int tem=t-cnt-s1-s2;
    if(tem<0||tem&1) return ;
    for(int k=0;k<4;k++)
    {
        int xi,xj;
        xi=i+to[k][0];
        xj=j+to[k][1];
        if(data[xi][xj]!=X)
        {
            data[xi][xj]=X;
            dfs(xi,xj,cnt+1);
            data[xi][xj]=.;
        }
    }
    return ;
}

int main()
{
    while(cin>>n>>m>>t)
    {
       if(n==0&&m==0&&t==0) break;
       wall=0;
       for(int i=1;i<=n;i++)
        for(int j=1;j<=m;j++)
        {
            cin>>data[i][j];
            if(data[i][j]==S)
            {
                ki=i;kj=j;
            }
            else if(data[i][j]==D)
            {
                zi=i;zj=j;
            }
            else if(data[i][j]==X)
            wall++;
        }
       if(n*m-wall<t)
       {
           cout<<"NO"<<endl;
           continue;
       }
       flag=0;
       data[ki][kj]=X;
       dfs(ki,kj,0);
       if(flag)
       cout<<"YES"<<endl;
       else
       cout<<"NO"<<endl;
    }
    return 0;
}

 

hdu 1010 Tempter of the Bone

标签:

原文地址:http://www.cnblogs.com/nefu929831238/p/5515781.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!