码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 2136(质数筛选+整数分解)

时间:2016-05-23 17:22:10      阅读:181      评论:0      收藏:0      [点我收藏+]

标签:

Largest prime factor

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9993    Accepted Submission(s): 3528


Problem Description
Everybody knows any number can be combined by the prime number.
Now, your task is telling me what position of the largest prime factor.
The position of prime 2 is 1, prime 3 is 2, and prime 5 is 3, etc.
Specially, LPF(1) = 0.
 

 

Input
Each line will contain one integer n(0 < n < 1000000).
 

 

Output
Output the LPF(n).
 

 

Sample Input
1 2 3 4 5
 

 

Sample Output
0 1 2 1 3
 
#include <stdio.h>
#include <math.h>
#include <iostream>
#include <algorithm>
#include <string.h>
#include <stdlib.h>
using namespace std;
typedef long long LL;
const int N = 1000000;
bool p[N]; ///为false代表是素数
int idx[N];
void init(){
    memset(p,false,sizeof(p));
    int id = 1;
    for(int i=2;i<N;i++){
        if(!p[i]){
            idx[i] = id++;
            for(LL j=(LL)i*i;j<N;j+=i){
                p[j] = true;
            }
        }
    }
}
int getMax(int n){
    int Max = -1;
    for(int i=2;i*i<=n;i++){
        if(n%i==0){
            while(n%i==0){
                n/=i;
            }
            Max = max(i,Max);
        }
    }
    if(n>1) Max = max(Max,n);
    return Max;
}
int main()
{
    init();
    int n;
    while(scanf("%d",&n)!=EOF){
        if(n==1) printf("0\n");
        else{
            int Max = getMax(n);
            printf("%d\n",idx[Max]);
        }
    }
}

 

hdu 2136(质数筛选+整数分解)

标签:

原文地址:http://www.cnblogs.com/liyinggang/p/5520376.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!