码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3070 Fibonacci

时间:2016-05-23 20:49:40      阅读:219      评论:0      收藏:0      [点我收藏+]

标签:

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

技术分享.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

矩阵快速幂入门题,构造矩阵[fn,fn-1]*[1,1]在自己敲一遍模板就行了。
             [0 ,0 ] [1,0]


#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
typedef long long int LL;
using namespace std;

int n,mod=10000;

struct Matrix
{
    int a[2][2];
    Matrix(){memset(a,0,sizeof(a));}
    Matrix operator* (const Matrix &p)
    {
        Matrix res;
        for(int i=0;i<2;i++)
        {
            for(int j=0;j<2;j++)
            {
                for(int k=0;k<2;k++)
                {
                    res.a[i][j]+=(a[i][k]*p.a[k][j]%mod);
                }
                res.a[i][j]%=mod;
            }
        }
        return res;
    }
}ans,base;

Matrix quick_pow(Matrix base,int k)
{
    Matrix res;
    for(int i=0;i<2;i++)
    {
        res.a[i][i]=1;
    }
    while(k)
    {
        if(k&1)  res=res*base;
        base=base*base;
        k>>=1;
    }
    return res;
}

void init_Matrix()
{
    ans.a[0][0]=1;
    ans.a[0][1]=0;
    ans.a[1][0]=0;
    ans.a[1][1]=0;
    base.a[0][0]=1;
    base.a[0][1]=1;
    base.a[1][0]=1;
    base.a[1][1]=0;
}

int main()
{
    while(scanf("%d",&n)&&n!=-1)
    {
        init_Matrix();
        if(n==0) printf("0\n");
        else if(n==1) printf("1\n");
        else
        {
            ans=ans*quick_pow(base,n-1);
            printf("%d\n",ans.a[0][0]);
        }
    }
    return 0;
}

 

POJ 3070 Fibonacci

标签:

原文地址:http://www.cnblogs.com/PrimeXuan/p/5521096.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!