码迷,mamicode.com
首页 > 其他好文 > 详细

杭电 2095

时间:2014-08-01 19:50:52      阅读:254      评论:0      收藏:0      [点我收藏+]

标签:位运算   杭电   数学   c   acm   

find your present (2)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/1024 K (Java/Others)
Total Submission(s): 15295    Accepted Submission(s): 5797


Problem Description
In the new year party, everybody will get a "special present".Now it‘s your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and your present‘s card number will be the one that different from all the others, and you can assume that only one number appear odd times.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from all the others.
 

Input
The input file will consist of several cases.
Each case will be presented by an integer n (1<=n<1000000, and n is odd) at first. Following that, n positive integers will be given in a line, all integers will smaller than 2^31. These numbers indicate the card numbers of the presents.n = 0 ends the input.
 

Output
For each case, output an integer in a line, which is the card number of your present.
 

Sample Input
5 1 1 3 2 2 3 1 2 1 0
 

Sample Output
3 2
Hint
Hint
use scanf to avoid Time Limit Exceeded
 

Author
8600
 

Source
 
 
这道题乍一看是用数组,但是要是用数组的话,因为题上的数很大 编译器会崩溃,想我一开始就是用的数组就是编辑器崩溃了,后来正好看到了位运算,想到或许可以用位运算优化,要是用异或的话,那么相同的数运算运算就是0,那么那个剩下的唯一的奇数,(实际上在这里就不用在判断是不是奇数了),就是要求的,于是又一下代码:
<span style="font-size:18px;">#include<stdio.h>
int main()
{
	int n,x,m;
	while(~scanf("%d",&n),n)
	{
		x=0;
		while(n--)
		{
			scanf("%d",&m);
			x^=m;
		}
		printf("%d\n",x);
	}
	return 0;
}</span>
<span style="font-size:18px;"></span> 
<span style="font-size:18px;">下面是之前我的错误的代码:</span>
<span style="font-size:18px;"></span><p>#include<stdio.h>
#include<string.h>
int a[1000001];
int s[1000001];
int b[1000001];
int main()
{
 int n,i;</p><p> while(~scanf("%d",&n),n)
 {
  memset(s,0,sizeof(s));
  for(i=1;i<=n;i++)
  scanf("%d",&a[i]);
  for(i=1;i<=n;i++)
  {
   s[a[i]]++;
   b[i]=i;  
  }
  for(i=1;i<=n;i++)
  {
   if(s[a[i]]&1)
   {
    printf("%d\n",b[i]);
   }
  }
 }
 return 0;
}
</p>
<span style="font-size:18px;">//能够运行,但是因为数组设的过大,导致编译器崩溃没法通过。</span>

杭电 2095,布布扣,bubuko.com

杭电 2095

标签:位运算   杭电   数学   c   acm   

原文地址:http://blog.csdn.net/ice_alone/article/details/38339631

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!