码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1518 Square

时间:2016-05-24 22:20:32      阅读:193      评论:0      收藏:0      [点我收藏+]

标签:

Problem Description
Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?
 

 

Input
The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.
 

 

Output
For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".
 

 

Sample Input
3 4 1 1 1 1 5 10 20 30 40 50 8 1 7 2 6 4 4 3 5
 

 

Sample Output
yes no yes
 
//听说这是又是一道经典搜索题。。。好吧。。依然是照大神的代码敲得。。。
 
#include <iostream>
#include <cstring>

using namespace std;
int t,n,sum,flag;
int a[25],visit[25];

void dfs(int bian,int l,int k)
{
    if(bian==5)
    {
        flag=1;
        return ;
    }
    if(l==sum)
    {
        dfs(bian+1,0,0);
        if(flag) return ;
    }
    for(int i=k;i<n;i++)
    {
        if(!visit[i]&&a[i]+l<=sum)
        {
            visit[i]=1;
            dfs(bian,a[i]+l,i+1);
            if(flag ) return ;
            visit[i]=0;
        }
    }
    return ;
}

int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        cin>>n;
        sum=0;
        for(int i=0;i<n;i++)
        {
            cin>>a[i];  sum+=a[i];
        }
        if(sum%4!=0)
        {
            cout<<"no"<<endl;
            continue;
        }
        sum=sum/4;
        int q=-1;
        for(int i=0;i<n;i++)
        {
            if(a[i]>sum)
            {
                //cout<<"#####     "<<a[i]<<" "<<sum<<endl;
                q=i;
                break;
            }
        }
        if(q!=-1)
        {
            cout<<"no"<<endl;
            continue;
        }
        memset(visit,0,sizeof(visit));
        flag=0;
        dfs(1,0,0);
        if(flag ) cout<<"yes"<<endl;
        else cout<<"no"<<endl;
    }
    return 0;
}

 

hdu 1518 Square

标签:

原文地址:http://www.cnblogs.com/nefu929831238/p/5524745.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!