码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 2669(扩展欧几里得)

时间:2016-05-25 20:43:37      阅读:215      评论:0      收藏:0      [点我收藏+]

标签:

Romantic

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4400    Accepted Submission(s): 1852


Problem Description
The Sky is Sprite.
The Birds is Fly in the Sky.
The Wind is Wonderful.
Blew Throw the Trees
Trees are Shaking, Leaves are Falling.
Lovers Walk passing, and so are You.
................................Write in English class by yifenfei

技术分享

Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead.
 

 

Input
The input contains multiple test cases.
Each case two nonnegative integer a,b (0<a, b<=2^31)
 

 

Output
output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead.
 

 

Sample Input
77 51 10 44 34 79
 

 

Sample Output
2 -3 sorry 7 -3
 
题解:由ax+by = gcd(a,b) 当 a,b互素是才会有解。然后X要是尽量小的正数,假设我们得到的是 X0 ,在有解的情况下方程ax+by=c的通解为 {X0*(c/d)+k*b/gcd(a,b)} (k = ..-2,-1,0,1,2..)
所以我们可以得到在最小的X为 (X0%b+b)%b.代入得Y
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
typedef long long LL;

LL extend_gcd(LL a,LL b,LL &x,LL &y){
    if(!b){
        x=1,y = 0;
        return a;
    }else{
        LL x1,y1;
        LL d = extend_gcd(b,a%b,x1,y1);
        x = y1;
        y = x1 - a/b*y1;
        return d;
    }
}
int main()
{
    LL a,b,x,y;
    while(~scanf("%lld%lld",&a,&b)){
        LL d = extend_gcd(a,b,x,y);
        if(d!=1){
            printf("sorry\n");
        }else{
            x = (x%b+b)%b;
            y = (1-a*x)/b;
            printf("%lld %lld\n",x,y);
        }
    }
    return 0;
}

 

hdu 2669(扩展欧几里得)

标签:

原文地址:http://www.cnblogs.com/liyinggang/p/5528236.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!