标签:杭电 贪心
http://acm.hdu.edu.cn/showproblem.php?pid=2124
Repair the Wall
Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2076 Accepted Submission(s): 1003
Problem Description
Long time ago , Kitty lived in a small village. The air was fresh and the scenery was very beautiful. The only thing that troubled her is the typhoon.
When the typhoon came, everything is terrible. It kept blowing and raining for a long time. And what made the situation worse was that all of Kitty‘s walls were made of wood.
One day, Kitty found that there was a crack in the wall. The shape of the crack is
a rectangle with the size of 1×L (in inch). Luckly Kitty got N blocks and a saw(锯子) from her neighbors.
The shape of the blocks were rectangle too, and the width of all blocks were 1 inch. So, with the help of saw, Kitty could cut down some of the blocks(of course she could use it directly without cutting) and put them in the crack, and the wall may be repaired
perfectly, without any gap.
Now, Kitty knew the size of each blocks, and wanted to use as fewer as possible of the blocks to repair the wall, could you help her ?
Input
The problem contains many test cases, please process to the end of file( EOF ).
Each test case contains two lines.
In the first line, there are two integers L(0<L<1000000000) and N(0<=N<600) which
mentioned above.
In the second line, there are N positive integers. The ith integer Ai(0<Ai<1000000000 ) means that the ith block has the size of 1×Ai (in inch).
Output
For each test case , print an integer which represents the minimal number of blocks are needed.
If Kitty could not repair the wall, just print "impossible" instead.
Sample Input
Sample Output
题目大意:有块墙破了,需要修补,破坏的地方是一个宽为1矩形,长度为L,有n块矩形木板(宽为1)长为A[i]。木板可以切割,求最少需要多少块木板。
AC代码:
#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
__int64 a[605];
bool cmp(__int64 a,__int64 b)
{
return a>b;
}
int main()
{
__int64 l,n,i,sum,tot;
while(~scanf("%I64d%I64d",&l,&n))
{
for(i=0; i<n; i++)
scanf("%I64d",&a[i]);
sort(a,a+n,cmp);
sum=0;
tot=0;
for(i=0; i<n; i++)
tot+=a[i];
if(tot<l) //如果所有木板的长度都小于缺口的长度,就补不了
{
printf("impossible\n");
continue;
}
else
{
for(i=0; i<n; i++)
{
if(l>=a[i])
{
sum++;
l=l-a[i];
}
else
{
if(l)//切割~
sum++;
break;
}
}
}
printf("%I64d\n",sum);
}
return 0;
}
杭电 2124 Repair the Wall,布布扣,bubuko.com
杭电 2124 Repair the Wall
标签:杭电 贪心
原文地址:http://blog.csdn.net/u012766950/article/details/38342239